天天看點

ZOJ-3469 Food Delivery

When we are focusing on solving problems, we usually prefer to stay in front of computers rather than go out for lunch. At this time, we may call for food delivery.

Suppose there are N people living in a straight street that is just lies on an X-coordinate axis. The ith person's coordinate is Xi meters. And in the street there is a take-out restaurant which has coordinates X meters. One day at lunchtime, each person takes an order from the restaurant at the same time. As a worker in the restaurant, you need to start from the restaurant, send food to the N people, and then come back to the restaurant. Your speed is V-1 meters per minute.

You know that the N people have different personal characters; therefore they have different feeling on the time their food arrives. Their feelings are measured by Displeasure Index. At the beginning, the Displeasure Index for each person is 0. When waiting for the food, the ith person will gain Bi Displeasure Index per minute.

If one's Displeasure Index goes too high, he will not buy your food any more. So you need to keep the sum of all people's Displeasure Index as low as possible in order to maximize your income. Your task is to find the minimal sum of Displeasure Index.

Input

The input contains multiple test cases, separated with a blank line. Each case is started with three integers N ( 1 <= N <= 1000 ), V ( V > 0), X ( X >= 0 ), then Nlines followed. Each line contains two integers Xi ( Xi >= 0 ), Bi ( Bi >= 0), which are described above.

You can safely assume that all numbers in the input and output will be less than 231- 1.

Please process to the end-of-file.

Output

For each test case please output a single number, which is the minimal sum of Displeasure Index. One test case per line.

Sample Input

5 1 0

1 1

2 2

3 3

4 4

5 5

Sample Output

55

題意:在一條x軸上有一些點,每個點會随着時間的增加點權不斷增加,你每次要取一個點。問最後能獲得的總點權最小是多少。

嗯,這個就是區間dp感覺比較複雜一些的?看大佬貌似隻是基礎題。。。。。

是我還是太天真了吧。

狀态上必須加上左右端點。然後你每次可以從左邊走或者從右邊走。。。實際上是4種情況。

注意花費,這裡的影響是目前的點增加的價值還有沒取的點的一個價值。實際上為什麼用dp就是因為這個影響。

看代碼應該會更好了解一些。。。

#include <cstdio>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <time.h>

using namespace std;
typedef long long LL;
const int inf = 0x3f3f3f3f;
const int mod = 1e9+7;
const int MAXN = 1000+7;
int n,v,x;
int sum[MAXN];
int dp[MAXN][MAXN][2];
int get_cost(int l,int r)
{
    if(l > r)return 0;
    return sum[r] - sum[l-1];
}
struct node
{
    int x,v;
    bool operator < (const node &a)const
    {
        return x < a.x;
    }
}p[MAXN];

int main()
{
    while(~scanf("%d%d%d",&n,&v,&x))
    {
        sum[0] = 0;
        memset(dp,inf,sizeof dp);
        for(int i = 1; i <= n; ++i)
        {
            scanf("%d%d",&p[i].x,&p[i].v);
        }
        p[++n].x = x;
        p[n].v = 0;
        sort(p+1,p+1+n);
        int pos = 1;
        for(int i = 1; i <= n; ++i)
        {
            sum[i] = sum[i-1] + p[i].v;
            if(p[i].x == x)pos = i;
        }
        
        dp[pos][pos][0] = dp[pos][pos][1] = 0;
        for(int i = pos; i >= 1; --i)
            for(int j = pos; j <= n; ++j)
        {
            int cost = get_cost(1,i-1) + get_cost(j+1,n);
            dp[i][j][0] = min(dp[i][j][0],dp[i+1][j][0] + (p[i+1].x - p[i].x)*(p[i].v + cost));
            dp[i][j][0] = min(dp[i][j][0],dp[i+1][j][1] + (p[j].x - p[i].x)*(p[i].v + cost));
            dp[i][j][1] = min(dp[i][j][1],dp[i][j-1][0] + (p[j].x - p[i].x)*(p[j].v + cost));
            dp[i][j][1] = min(dp[i][j][1],dp[i][j-1][1] + (p[j].x - p[j-1].x)*(p[j].v + cost));
        }
        printf("%d\n",min(dp[1][n][0],dp[1][n][1])*v);
    }
    return 0;
}
           
然後感覺數位dp題型比較複雜啊,雖然比線性dp要好一些吧,還是先做多一些題看看。