天天看點

hdu 5900 QSC and Master

QSC and MasterTime Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 3326 Accepted Submission(s): 1190

Problem Description Every school has some legends, Northeastern University is the same.

Enter from the north gate of Northeastern University,You are facing the main building of Northeastern University.Ninety-nine percent of the students have not been there,It is said that there is a monster in it.

QSCI am a curious NEU_ACMer,This is the story he told us.

It’s a certain period,QSCI am in a dark night, secretly sneaked into the East Building,hope to see the master.After a serious search,He finally saw the little master in a dark corner. The master said:

“You and I, we’re interfacing.please solve my little puzzle!

There are N pairs of numbers,Each pair consists of a key and a value,Now you need to move out some of the pairs to get the score.You can move out two continuous pairs,if and only if their keys are non coprime(their gcd is not one).The final score you get is the sum of all pair’s value which be moved out. May I ask how many points you can get the most?

The answer you give is directly related to your final exam results~The young man~”

QSC is very sad when he told the story,He failed his linear algebra that year because he didn’t work out the puzzle.

Could you solve this puzzle?

(Data range:1<=N<=300

1<=Ai.key<=1,000,000,000

0<Ai.value<=1,000,000,000)

Input First line contains a integer T,means there are T(1≤T≤10) test case。

Each test case start with one integer N . Next line contains N integers,means Ai.key.Next line contains N integers,means Ai.value.

Output For each test case,output the max score you could get in a line.

Sample Input3

3

1 2 3

1 1 1

3

1 2 4

1 1 1

4

1 3 4 3

1 1 1 1

Sample Output

2

這道題目可以講的點太多了

1.

求最大公因數的方法

int gcd(int a,int b)
{
 return b==0?a:gcd(b,a%b);
}
           

2.初态的設定:

memset(dp,0,sizeof(dp));//很重要
memset(visit,0,sizeof(visit));
for(i=1;i<=m;i++)
{
   dp[i][i]=0;
   if(gcd(w[i],w[i+1])!=1)
   {
    dp[i][i+1]=v[i]+v[i+1];
    visit[i][i+1]=1;
   }
}
           

3.dp過程

for(k=i;k<j;k++)
{
     if(dp[i][k]+dp[k+1][j]>dp[i][j])
     {
      dp[i][j]=dp[i][k]+dp[k+1][j]; 
      if(visit[i][k]&&visit[k+1][j])
      {
       visit[i][j]=1;
      }
     }
}
if(visit[i+1][j-1]&&gcd(w[i],w[j])!=1)//可以全取,肯定是最優解 
{
     visit[i][j]=1;
     dp[i][j]=dp[i+1][j-1]+v[i]+v[j];
 }
           

全部的代碼:

注意:擦完一部分之後剩餘的部分就相鄰了

#include<iostream>    
#include<cstdio>
#include<string.h>
using namespace std;
#define N 300+5
#define min(a,b) a>b?b:a
#define max(a,b) a>b?a:b
typedef long long ll;
ll w[N];
ll v[N];
ll dp[N][N];
int visit[N][N];
int gcd(int a,int b)
{
 return b==0?a:gcd(b,a%b);
}
int main()
{
 int n;
 scanf("%d",&n);
 int i,j,k,len;
 while(n--)
 {
  int m;
  scanf("%d",&m);
  for(i=1;i<=m;i++)
  {
   scanf("%lld",&w[i]);
  }
  for(i=1;i<=m;i++)
  {
   scanf("%lld",&v[i]);
  }
  memset(dp,0,sizeof(dp));//很重要 
  memset(visit,0,sizeof(visit));
  for(i=1;i<=m;i++)
  {
   dp[i][i]=0;
   if(gcd(w[i],w[i+1])!=1)
   {
    dp[i][i+1]=v[i]+v[i+1];
    visit[i][i+1]=1;
   }
  }
  for(len=3;len<=m;len++)
  {
   for(i=1;i+len-1<=m;i++)
   {
    j=i+len-1;
    for(k=i;k<j;k++)
    {
     if(dp[i][k]+dp[k+1][j]>dp[i][j])
     {
      dp[i][j]=dp[i][k]+dp[k+1][j]; 
      if(visit[i][k]&&visit[k+1][j])
      {
       visit[i][j]=1;
      }
     }
    }
    if(visit[i+1][j-1]&&gcd(w[i],w[j])!=1)//可以全取,肯定是最優解 
    {
     visit[i][j]=1;
     dp[i][j]=dp[i+1][j-1]+v[i]+v[j];
    }
   }
  }
  cout<<dp[1][m]<<endl;
 } 
}