天天看點

hdu 5900 QSC and Master (區間dp)QSC and Master

QSC and Master

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 1086    Accepted Submission(s): 429

Problem Description Every school has some legends, Northeastern University is the same.

Enter from the north gate of Northeastern University,You are facing the main building of Northeastern University.Ninety-nine percent of the students have not been there,It is said that there is a monster in it.

QSCI am a curious NEU_ACMer,This is the story he told us.

It’s a certain period,QSCI am in a dark night, secretly sneaked into the East Building,hope to see the master.After a serious search,He finally saw the little master in a dark corner. The master said:

“You and I, we're interfacing.please solve my little puzzle!

There are N pairs of numbers,Each pair consists of a key and a value,Now you need to move out some of the pairs to get the score.You can move out two continuous pairs,if and only if their keys are non coprime(their gcd is not one).The final score you get is the sum of all pair’s value which be moved out. May I ask how many points you can get the most?

The answer you give is directly related to your final exam results~The young man~”

QSC is very sad when he told the story,He failed his linear algebra that year because he didn't work out the puzzle.

Could you solve this puzzle?

(Data range:1<=N<=300

1<=Ai.key<=1,000,000,000

0<Ai.value<=1,000,000,000)

Input First line contains a integer T,means there are T(1≤T≤10) test case。

  Each test case start with one integer N . Next line contains N integers,means Ai.key.Next line contains N integers,means Ai.value.

Output For each test case,output the max score you could get in a line.  

Sample Input

3
3
1 2 3
1 1 1
3
1 2 4
1 1 1
4
1 3 4 3
1 1 1 1
 
        

Sample Output

0
2
0
        

Source 2016 ACM/ICPC Asia Regional Shenyang Online

題意:略

#include<bits/stdc++.h>
using namespace std;
#define LL long long
LL key[330],val[330];
LL dp[330][330],sum[330];
bool ok[330][330];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n;
        scanf("%d",&n);
        for(int i=1;i<=n;i++) scanf("%lld",&key[i]);
        sum[0]=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%lld",&val[i]);
            sum[i]=sum[i-1]+val[i];
        }
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                if(j<=i) ok[i][j]=false;//這種情況規定第i位和第j位不能一起move
                else if(__gcd(key[i],key[j])==1) ok[i][j]=false;
                else ok[i][j]=true;
            }
        }
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                if(j==i+1&&ok[i][j]) dp[i][j]=val[i]+val[j];
                else dp[i][j]=0;
            }
        }
        ///如果區間[i,j]都被move掉了,那麼dp[i][j]==sum[j]-sum[i-1]
        for(int l=1;l<=n;l++)
        {
            for(int i=1;i+l<=n;i++)
            {
                int j=i+l;
                for(int k=i;k<=j;k++)
                {
                    if(ok[i][k]&&dp[i+1][k-1]==sum[k-1]-sum[i])///如果i和k位能一起move,而且[i+1,k-1]都被move掉了,那麼嘗試i和k位move
                        dp[i][j]=max(dp[i][j],dp[i+1][k-1]+dp[k+1][j]+val[i]+val[k]);
                    if(ok[k][j]&&dp[k+1][j-1]==sum[j-1]-sum[k])///如果k和j位能一起move,而且[k+1,j-1]都被move掉了,那麼嘗試k和j位move
                        dp[i][j]=max(dp[i][j],dp[k+1][j-1]+dp[i][k-1]+val[k]+val[j]);
                    dp[i][j]=max(dp[i][j],dp[i+1][j-1]);
                    dp[i][j]=max(dp[i][j],dp[i][j-1]);
                    dp[i][j]=max(dp[i][j],dp[i+1][j]);
                }
            }
        }
        printf("%lld\n",dp[1][n]);
    }
    return 0;
}