天天看點

GZHU18級寒假訓練:Cancer's Trial-第五題

HDU-2577

  • Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.
  • Input

    The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.

  • Output

    For each test case, you must output the smallest times of typing the key to finish typing this string.

  • Sample Input

    3

    Pirates

    HDUacm

    HDUACM

  • Sample Output

    8

    8

    8

  • Hint

    The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8.

    The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8

    The string “HDUACM”, can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8

    題解

    動态規劃(DP)題,題目大意:給你一個字元串,問要至少按多少次鍵盤才能打出這些字母,有大寫和小寫,可以按大寫鎖,也可以按shift。最後打完後,大寫鎖是關燈的(小寫)。

    是以用DP[ ][ ]來記錄大小寫狀态。

#include<string.h>
#include<stdio.h>
int min(int a,int b)
{
return a<b?a:b;
}
int main()
 
{
    int b[101][2];
    char a[10010];
    int n,i,l;
    scanf("%d",&n);
    getchar();
    while(n--)
    {
        gets(a);
        b[0][0]=0;
        b[0][1]=1;
        for(i=0;a[i]!='\0';i++)
        {
           if(a[i]>='A'&&a[i]<='Z')    //如果需求大寫 
           {
                b[i+1][1]=min(b[i][0]+2,b[i][1]+1);//寫完是大寫的狀态 
                b[i+1][0]=min(b[i][0]+2,b[i][1]+2);//寫完是小寫的狀态 
            }
           else                        //如果需求小寫 
           {
                b[i+1][1]=min(b[i][0]+2,b[i][1]+2);
                b[i+1][0]=min(b[i][0]+1,b[i][1]+2);
           }
       }
       l=min(b[i][1]+1,b[i][0]);
       printf("%d\n",l);
    }
    return 0;
}

           

代碼出處:https://blog.csdn.net/sm9sun/article/details/53241628