天天看点

GZHU18级寒假训练:Cancer's Trial-第五题

HDU-2577

  • Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.
  • Input

    The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.

  • Output

    For each test case, you must output the smallest times of typing the key to finish typing this string.

  • Sample Input

    3

    Pirates

    HDUacm

    HDUACM

  • Sample Output

    8

    8

    8

  • Hint

    The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8.

    The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8

    The string “HDUACM”, can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8

    题解

    动态规划(DP)题,题目大意:给你一个字符串,问要至少按多少次键盘才能打出这些字母,有大写和小写,可以按大写锁,也可以按shift。最后打完后,大写锁是关灯的(小写)。

    所以用DP[ ][ ]来记录大小写状态。

#include<string.h>
#include<stdio.h>
int min(int a,int b)
{
return a<b?a:b;
}
int main()
 
{
    int b[101][2];
    char a[10010];
    int n,i,l;
    scanf("%d",&n);
    getchar();
    while(n--)
    {
        gets(a);
        b[0][0]=0;
        b[0][1]=1;
        for(i=0;a[i]!='\0';i++)
        {
           if(a[i]>='A'&&a[i]<='Z')    //如果需求大写 
           {
                b[i+1][1]=min(b[i][0]+2,b[i][1]+1);//写完是大写的状态 
                b[i+1][0]=min(b[i][0]+2,b[i][1]+2);//写完是小写的状态 
            }
           else                        //如果需求小写 
           {
                b[i+1][1]=min(b[i][0]+2,b[i][1]+2);
                b[i+1][0]=min(b[i][0]+1,b[i][1]+2);
           }
       }
       l=min(b[i][1]+1,b[i][0]);
       printf("%d\n",l);
    }
    return 0;
}

           

代码出处:https://blog.csdn.net/sm9sun/article/details/53241628