天天看點

GZHU18級寒假訓練:Virgo's Trial-I

UVA-10020(貪心)

  • Given several segments of line (int the X axis) with coordinates [Li , Ri ]. You are to choose the minimal amount of them, such they would completely cover the segment [0, M].
  • Input

    The first line is the number of test cases, followed by a blank line.

    Each test case in the input should contains an integer M (1 ≤ M ≤ 5000), followed by pairs “Li Ri” (|Li |, |Ri | ≤ 50000, i ≤ 100000), each on a separate line. Each test case of input is terminated by pair ‘0 0’.

    Each test case will be separated by a single line.

  • Output

    For each test case, in the first line of output your programm should print the minimal number of line

    segments which can cover segment [0, M]. In the following lines, the coordinates of segments, sorted

    by their left end (Li), should be printed in the same format as in the input. Pair ‘0 0’ should not be

    printed. If [0, M] can not be covered by given line segments, your programm should print ‘0’ (without

    quotes).

    Print a blank line between the outputs for two consecutive test cases.

  • Sample Input

    2

    1

    -1 0

    -5 -3

    2 5

    0 0

    1

    -1 0

    0 1

    0 0

  • Sample Output

    1

    0 1

題意:給出了一些數軸上的範圍[L,R]和m,問這些範圍在數軸上是否能完全覆寫[0,m]這個範圍,如果可以輸出最小需要幾個範圍可以覆寫,把他們按左範圍排序輸出。

  • 貪心算法。
#include<iostream>
using namespace std;


vector<pair<int,int> >v,ans;

bool cmp(pair<int,int> p1,pair<int,int>p2)
{
    return p1.second>p2.second;
}
int main()
{
   int T;
   while(cin>>T)
   {
       while(T--)
       {
           v.clear();
           ans.clear();
           int n;
           cin>>n;
           int l,r;
           while(cin>>l>>r&&(l||r))
           {
               if(!(r<=0||l>=n))
               v.push_back(make_pair(l,r));
           }
           sort(v.begin(),v.end(),cmp);
           int now=0;
           while(now<n)
           {
               bool flag=false;
               for(int i=0;i<v.size();i++)
               {
                   if(v[i].first<=now&&v[i].second>now)
                   {
                       ans.push_back(v[i]);
 
                       now=v[i].second;
                       v.erase(v.begin()+i);
                       flag=true;
                       i--;
                   }
               }
               if(!flag)
                break;
           }
           if(T)
            cout<<endl;
           if(now>=n)
           {
               cout<<ans.size()<<endl;
               for(int i=0;i<ans.size();i++)
               {
                   cout<<ans[i].first<<' '<<ans[i].second<<endl;
               }
           }
           else
           {
               cout<<0<<endl;
           }
       }
   }
    return 0;
}