天天看點

poj 1286 Necklace of Beads

Necklace of Beads

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 6302 Accepted: 2628

Description

Beads of red, blue or green colors are connected together into a circular necklace of n beads ( n < 24 ). If the repetitions that are produced by rotation around the center of the circular necklace or reflection to the axis of symmetry are all neglected, how many different forms of the necklace are there? 

poj 1286 Necklace of Beads

Input

The input has several lines, and each line contains the input data n. 

-1 denotes the end of the input file. 

Output

The output should contain the output data: Number of different forms, in each line correspondent to the input data.

Sample Input

4
5
-1
      

Sample Output

21
39      

題目大意:就是有三種顔色給一竄珠子塗顔色,加上旋轉和翻折出現相同的情況算一中。

又一道組合數學初級題目,就套用polya定理的公式就搞定了。哈哈,今天做的兩題基本代碼,基本思路都一樣。

就分兩大類考慮就完事,代碼:

#include<iostream>
#include<fstream>
#include<iomanip>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cstdlib>
#include<cmath>
#include<set>
#include<map>
#include<queue>
#include<stack>
#include<string>
#include<vector>
#include<sstream>
#include<cassert>
using namespace std;
#define LL long long
LL gcd(LL a, LL b) {
    if(b == 0) return a;
    else return gcd(b, a % b);
}

LL polya(LL n) {
    LL ans=0;
    for(LL i=0; i<n; i++) {
        ans+=pow(3.0,gcd(i,n)+0.0);
    }
    if(n%2==1) {
        ans+=n*pow(3.0,(n+1)/2);
    } else {
        ans+=n/2*pow(3.0,n/2);
        ans+=n/2*pow(3.0,n/2+1);
    }
    return ans/n/2;

}

int main() {
    LL n;
    while(cin>>n) {
        if(n==-1)break;

        if(n<=0) {
            printf("0\n");
            continue;
        } else {
            printf("%lld\n",polya(n));
        }

    }

    return 0;
}
           

繼續閱讀