1145 Hashing - Average Search Time(25 分)
The task of this problem is simple: insert a sequence of distinct positive integers into a hash table first. Then try to find another sequence of integer keys from the table and output the average search time (the number of comparisons made to find whether or not the key is in the table). The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.
Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.
Input Specification:
Each input file contains one test case. For each case, the first line contains 3 positive numbers: MSize, N, and M, which are the user-defined table size, the number of input numbers, and the number of keys to be found, respectively. All the three numbers are no more than 104. Then N distinct positive integers are given in the next line, followed by M positive integer keys in the next line. All the numbers in a line are separated by a space and are no more than 105.
Output Specification:
For each test case, in case it is impossible to insert some number, print in a line
X cannot be inserted.
where
X
is the input number. Finally print in a line the average search time for all the M keys, accurate up to 1 decimal place.
Sample Input:
4 5 4
10 6 4 15 11
11 4 15 2
Sample Output:
15 cannot be inserted.
2.8
不錯的文章 :https://blog.csdn.net/qq_27093465/article/details/52348366
思路:
哈希函數:
H(key) = key % TSize
處理沖突方法:
Hi = (H(key) + di) % TSize
其中di∈
1*1
,
-1*1
,
2*2
,
-2*2
, ···
k*k
,
-k*k
(k < TSize)
每次查詢基準為1步,d從0*0開始
題目中提到
with positive increments only
隻需要考慮正增量即可。
插入情況:如果
k ∈[0, Tsize)
内都沒有找到空位置,則插入失敗。
查詢情況:執行和插入一樣的操作,如果定位到的元素和目前元素相同,說明找到了;如果定位到的位置是空的,說明目前查詢的元素不在哈希表中;如果
k ∈[0, Tsize)
内都沒有找到,說明該元素無法插入,将查詢總數+1。
題目中提醒:如果給定的TSize是合數,則要變為>Tsize的最小素數。比如10000 ->10007
#include <iostream>
#include <vector>
#include <cmath>
using namespace std;
int msize, n, m;
vector<int>ef;
int isprime(int n)
{
if (n < 2)return 0;
for (int i = 2; i <= sqrt(n); ++i)
{
if (n%i == 0)
{
return 0;
}
}
return 1;
}
void insert(int key)
{
int i = 0,h;
while (i < msize)
{
h = (key % msize + i * i)%msize;
if (ef[h] == 0)
{
ef[h] = key;
return;
}
i++;
}
printf("%d cannot be inserted.\n",key);
}
int search(int key)
{
int h,cnt = 0, i = 0;
while (i < msize)
{
cnt++;
h = (key % msize + i * i) % msize;
if (ef[h] == 0||ef[h]==key)
{
return cnt;
}
i++;
}
return cnt + 1;
}
int main()
{
int i;
double sum = 0;
scanf("%d %d %d", &msize, &n, &m);
while (!isprime(msize))msize++;
ef=vector<int>(msize);
for (i = 0; i < n; ++i)
{
int val;
scanf("%d", &val);
insert(val);
}
for (i = 0; i < m; ++i)
{
int val;
scanf("%d", &val);
sum+=search(val);
}
printf("%.1lf\n", sum / m);
}