天天看點

PAT - 甲級 - 1064. Complete Binary Search Tree (30)(完全二叉搜尋樹層次周遊)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key. 
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key. 
  • Both the left and right subtrees must also be binary search trees. 

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0
      

Sample Output:

6 3 8 1 5 7 9 0 2 4
      

給定條件:

1.給定n個節點

2.這n個節點是屬于一顆二叉搜尋樹的節點,并且這棵樹是完全二叉樹

要求:

1.這棵樹的層次周遊結果

求解:

1.因為是二叉搜尋樹,是以将n個節點排序後可得到該二叉樹中序周遊的結果

2.如果根節點的編号為x,那麼它的左子樹根節點是2*x,右子樹根節點是2*x+1 (x!=0),編号順序即層次周遊順序

3.根據中序周遊結果,更新層次周遊中的節點資訊

#include<cstdio>
#include<algorithm>
using namespace std;

int n, id;
int a[1005];
int ans[1005];

void dfs(int index){
	if(index > n) return ;

	dfs(index*2);
	ans[index] = a[id++]; 
	dfs(index*2+1);
}
int main(){
	while(scanf("%d",&n) != EOF){
		id = 1;
		for(int i = 1; i <= n; i++){
			scanf("%d",&a[i]);
		}
		sort(a+1,a+n+1);
		dfs(1);
		for(int i = 1; i <= n; i++){
			if(i!=1) printf(" ");
			printf("%d", ans[i]);
		}
	}
	return 0;
}