天天看點

1075 PAT Judge (25分)題解:法二:

The ranklist of PAT is generated from the status list, which shows the scores of the submissions. This time you are supposed to generate the ranklist for PAT.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive integers, N (≤10​4​​), the total number of users, K (≤5), the total number of problems, and M (≤10​5​​), the total number of submissions. It is then assumed that the user id's are 5-digit numbers from 00001 to N, and the problem id's are from 1 to K. The next line contains K positive integers 

p[i]

 (

i

=1, ..., K), where 

p[i]

 corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submission in the following format:

user_id problem_id partial_score_obtained
           

where 

partial_score_obtained

 is either −1 if the submission cannot even pass the compiler, or is an integer in the range [0, 

p[problem_id]

]. All the numbers in a line are separated by a space.

Output Specification:

For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] ... s[K]
           

where 

rank

 is calculated according to the 

total_score

, and all the users with the same 

total_score

 obtain the same 

rank

; and 

s[i]

 is the partial score obtained for the 

i

-th problem. If a user has never submitted a solution for a problem, then "-" must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id's. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:

7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0
           

Sample Output:

1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -
           

題解:

第一次送出:測試點4錯誤(一開始不懂為什麼會錯,感覺代碼邏輯沒有問題)

然後去看了算法筆記的題解思路和我差不多,檢查了一遍自己的條件判斷後 還是感覺自己沒問題

後來又重新分析對比了一下 寶典題解 發現id初始化存在問題

代碼:

#include <iostream>
#include <algorithm>

using namespace std;

struct User
{
	int id;
	int score[5];
	int total_score;
	int full_score;
	int isshow;
	User() {
		id = 0;
		fill(score, score + 5, -1);
		total_score = 0;
		full_score = 0;
		isshow = 0;
	}

};

bool cmp(User a, User b) {
	return a.isshow > b.isshow;
}
bool cmp2(User a, User b) {
	if (a.total_score != b.total_score) return a.total_score > b.total_score;
	else if (a.full_score != b.full_score) return a.full_score > b.full_score;
	else return a.id < b.id;
}
User user[10001];

int main() {
	for (int i = 0; i < 10001; i++) user[i].id = i;

	int n, k, m, p[5] = { -1 };
	cin >> n >> k >> m;

	for (int i = 0; i < k; i++)
		cin >> p[i];

	for (int i = 0; i < m; i++)
	{
		int id, pid, pscore;
		cin >> id >> pid >> pscore;
		user[id].id = id;
		if (pscore > user[id].score[pid - 1])
		{
			if (user[id].score[pid - 1] != -1) user[id].total_score = user[id].total_score - user[id].score[pid - 1] + pscore;
			else user[id].total_score += pscore;
			if (pscore == p[pid - 1] && user[id].score[pid - 1] < p[pid - 1]) user[id].full_score++;
			user[id].score[pid - 1] = pscore;
			user[id].isshow = 1;
		}
		else if (pscore == -1 && user[id].score[pid - 1] == -1) user[id].score[pid - 1] = 0;
	}

	sort(user, user + 10001, cmp);
	sort(user, user + n, cmp2);

	int rank = 1;
	for (int i = 0; user[i].isshow == 1; i++)
	{
		if (i != 0 && user[i].total_score != user[i - 1].total_score) rank = i + 1;

		printf("%d %05d %d", rank, user[i].id, user[i].total_score);
		for (int j = 0; j < k; j++)
		{
			if (user[i].score[j] != -1) printf(" %d", user[i].score[j]);
			else printf(" -");
			if (j == k - 1) printf("\n");
		}
	}
    return 0;
}
           

法二:

#include <iostream>
#include <algorithm>
#include <unordered_map>
#include <vector>

using namespace std;

const int K = 6;

int n, k, m;
int p_score[K];

struct Student
{
    string id;
    int grade[K];
    int total, cnt;

    Student(){}
    Student(string _id) : id(_id)
    {
        for (int i = 1; i <= k; i ++ ) grade[i] = -2;
        total = cnt = 0;
    }

    void calc()
    {
        for (int i = 1; i <= k; i ++ )
        {
            total += max(0, grade[i]);
            if (grade[i] == p_score[i]) cnt ++ ;
        }
    }

    bool has_submit()
    {
        for (int i = 1; i <= k; i ++ )
            if (grade[i] >= 0)
                return true;
        return false;
    }

    bool operator< (const Student& t) const
    {
        if (total != t.total) return total > t.total;
        if (cnt != t.cnt) return cnt > t.cnt;
        return id < t.id;
    }
};

int main()
{
    unordered_map<string, Student> students;

    cin >> n >> k >> m;
    for (int i = 1; i <= k; i ++ ) cin >> p_score[i];

    while (m -- )
    {
        string u_id;
        int p_id, grade;
        cin >> u_id >> p_id >> grade;

        if (students.count(u_id) == 0) students[u_id] = Student(u_id);
        students[u_id].grade[p_id] = max(students[u_id].grade[p_id], grade);
    }

    vector<Student> res;
    for (auto& item: students)
    {
        auto& s = item.second;
        if (s.has_submit())
        {
            s.calc();
            res.push_back(s);
        }
    }

    sort(res.begin(), res.end());

    for (int i = 0, rank = 1; i < res.size(); i ++ )
    {
        if (i && res[i].total != res[i - 1].total) rank = i + 1;
        cout << rank << ' ' << res[i].id << ' ' << res[i].total;
        for (int j = 1; j <= k; j ++ )
            if (res[i].grade[j] == -2) cout << " -";
            else cout << ' ' << max(0, res[i].grade[j]);
        cout << endl;
    }

    return 0;
}
           

繼續閱讀