Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.
Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤104) - the total number of customers, and K (≤100) - the number of windows. Then N lines follow, each contains 2 times:
HH:MM:SS
- the arriving time, and P - the processing time in minutes of a customer. Here
HH
is in the range [00, 23],
MM
and
SS
are both in [00, 59]. It is assumed that no two customers arrives at the same time.
Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.
Output Specification:
For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.
Sample Input:
7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10
Sample Output:
8.2
題解:
關鍵在于視窗與排隊的模拟。簡單的解法是每個視窗記錄客戶完成的時刻。
下一個客戶通路時
視窗時間<客戶到達時間:說明客戶無需等待。
視窗時間>客戶到達時間:客戶需等待,計算等待時間。
#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
const int openTime = 8 * 3600;
const int closeTime = 17 * 3600;
struct node
{
int arriveTime, cost;
};
bool cmp(node a, node b) {
return a.arriveTime < b.arriveTime;
}
int main() {
int n, k;
cin >> n >> k;
vector<node> customers;
vector<int> window(k, openTime);
double res = 0.0;
for (int i = 0; i < n; i++)
{
int hh, mm, ss, pt;
node temp;
scanf("%d:%d:%d %d", &hh, &mm, &ss, &pt);
temp.arriveTime = hh * 3600 + mm * 60 + ss;
temp.cost = min(pt,60)*60;
if (temp.arriveTime <= closeTime)
customers.push_back(temp);
}
sort(customers.begin(), customers.end(), cmp);
for (int i = 0; i < customers.size(); i++)
{
int index = 0, finish = window[0];
for (int j = 1; j < k; j++)
{
if (finish>window[j])
{
finish = window[j];
index = j;
}
}
if (window[index] <= customers[i].arriveTime)
window[index] = customers[i].arriveTime + customers[i].cost;
else
{
res += (window[index] - customers[i].arriveTime);
window[index] += customers[i].cost;
}
}
printf("%.1f", res / 60 / customers.size());
return 0;
}