天天看點

騎士的移動(Knight Moves)

Knight Moves

Time Limit:3000MS Memory Limit:Unknown 64bit IO Format:%lld & %llu

Submit  Status

Description

騎士的移動(Knight Moves)

A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.

Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part.

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.

Input Specification

The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard.

Output Specification

For each test case, print one line saying "To get from xx to yy takes n knight moves.".

Sample Input

e2 e4
a1 b2
b2 c3
a1 h8
a1 h7
h8 a1
b1 c3
f6 f6      

Sample Output

To get from e2 to e4 takes 2 knight moves.
To get from a1 to b2 takes 4 knight moves.
To get from b2 to c3 takes 2 knight moves.
To get from a1 to h8 takes 6 knight moves.
To get from a1 to h7 takes 5 knight moves.
To get from h8 to a1 takes 6 knight moves.
To get from b1 to c3 takes 1 knight moves.
To get from f6 to f6 takes 0 knight moves.      

【分析】

       利用廣度優先搜尋尋找最短路徑。用way[r][c]記錄起點到達[r, c]位置所走的步數。用pos[r][c]來标記[r, c]位置是否被通路過。

用java語言編寫程式,代碼如下:

import java.io.BufferedInputStream;
import java.util.LinkedList;
import java.util.Queue;
import java.util.Scanner;

public class Main {
	public static void main(String[] args) {
		Scanner input = new Scanner(new BufferedInputStream(System.in));
		//位置移動
		final int[] dr = { -1, -2, -2, -1, 1, 2, 2, 1};
		final int[] dc = { -2, -1, 1, 2, 2, 1, -1, -2};
		while(input.hasNext()) {
			String from = input.next();
			String to = input.next();
			
			if(from.equals(to)) {
				System.out.println("To get from " + from + " to " + to +" takes 0 knight moves.");
				continue;
			}
			int[][] pos = new int[9][9];
			int[][] way = new int[9][9];
			//将輸入的位置轉化為數組的下标
			int fr = 9 - (from.charAt(1) - '0'); int fc = from.charAt(0) - 'a' + 1;
			int tr = 9 - (to.charAt(1) - '0'); int tc = to.charAt(0) - 'a' + 1;
			
			boolean arrive = false;
			Queue<KnightPos> q = new LinkedList<KnightPos>();
			q.add(new KnightPos(fr, fc));
			while(!q.isEmpty()) {
				KnightPos kp = q.poll();
				pos[kp.r][kp.c] = 1;//标記已被通路
				
				if(kp.r == tr && kp.c == tc)
					break;
				
				for(int i = 0; i < 8; i++) {
					int r = kp.r + dr[i];
					int c = kp.c + dc[i];
					
					if(r >= 1 && r <= 8 && c >= 1 && c <= 8 && pos[r][c] == 0) {
						pos[r][c] = 1;//标記已被通路
						way[r][c] = way[kp.r][kp.c] + 1;//從[kp.r, kp.c]向[r, c]走一步
						q.add(new KnightPos(r, c));
						if(r == tr && c == tc) { //走到終點,标記arrive,跳出循環
							arrive = true;
							break;
						}
						
					}
				}
				
				if(arrive)
					break;
			}
			System.out.println("To get from " + from + " to " + to +
					" takes " + way[tr][tc] + " knight moves.");
		}
	}
	
	static class KnightPos {
		int r, c;
		public KnightPos(int r, int c) {
			this.r = r;
			this.c = c;
		}
	}
}