天天看點

POJ3186 Treats for the Cows

FJ has purchased N (1 <= N <= 2000) yummy treats for the cows who get money for giving vast amounts of milk. FJ sells one treat per day and wants to maximize the money he receives over a given period time. 

The treats are interesting for many reasons:

  • The treats are numbered 1..N and stored sequentially in single file in a long box that is open at both ends. On any day, FJ can retrieve one treat from either end of his stash of treats.
  • Like fine wines and delicious cheeses, the treats improve with age and command greater prices.
  • The treats are not uniform: some are better and have higher intrinsic value. Treat i has value v(i) (1 <= v(i) <= 1000).
  • Cows pay more for treats that have aged longer: a cow will pay v(i)*a for a treat of age a.

Given the values v(i) of each of the treats lined up in order of the index i in their box, what is the greatest value FJ can receive for them if he orders their sale optimally? 

The first treat is sold on day 1 and has age a=1. Each subsequent day increases the age by 1.

Input

Line 1: A single integer, N 

Lines 2..N+1: Line i+1 contains the value of treat v(i)

Output

Line 1: The maximum revenue FJ can achieve by selling the treats

Sample Input

5
1
3
1
5
2      

Sample Output

43      

Hint

Explanation of the sample: 

Five treats. On the first day FJ can sell either treat #1 (value 1) or treat #5 (value 2). 

FJ sells the treats (values 1, 3, 1, 5, 2) in the following order of indices: 1, 5, 2, 3, 4, making 1x1 + 2x2 + 3x3 + 4x1 + 5x5 = 43.

題目給的題境有點抽象。讓我們想象有一個隻能從兩頭打開的酒,裡面的酒每放一天價格就會翻倍。每天你隻能從兩頭中的一頭拿出一瓶酒,那麼作為商人,你自然要找出拿酒的最優解了。

dp是顯然的,但是這道題和數字三角形一樣,是前一個值由後一個值決定,也就是你無法根據前一個值的狀态推出下一個狀态(如果那樣就是貪心了)。是以這個dp還有點麻煩。

用dp[i][j]表示第i天到第j天的最優解,那麼新增的某天價值即為a[i]*(n+i-j),兩個比較的為dp[i+1][j]和dp[i][j-1]各自加上新增的價值;因為是倒序的 是以從第n天開始循環。

AC代碼:

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;
int a[2010];
int dp[2010][2010];
int main()
{
    int n;
    while(cin>>n)
    {
        memset(a,0,sizeof(a));
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
            scanf("%d",a+i);
        for(int i=n;i>0;i--)
            for(int j=i;j<=n;j++)
            dp[i][j]=max(dp[i+1][j]+a[i]*(n+i-j),dp[i][j-1]+a[j]*(n+i-j));
       cout<<dp[1][n]<<endl;    

    }
    return 0;
}