天天看點

HDU 1312--Red and Black【DFS】Red and Black

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 11503    Accepted Submission(s): 7158

Problem Description There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile

'#' - a red tile

'@' - a man on a black tile(appears exactly once in a data set)

Output For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#[email protected]#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
[email protected]
###.###
..#.#..
..#.#..
0 0
        

Sample Output

45
59
6
13
        
#include <cstdio>
#include <cstring>
int n,m;
char map[100][100];
int dir[][2]={0,1,0,-1,1,0,-1,0};

int ans;
void dfs(int x,int y){
    map[x][y]='#';
    for(int i=0;i<4;++i){
        int fx=x+dir[i][0];
        int fy=y+dir[i][1];
        if(fx>=0 && fx<m && fy>=0 && fy<n && map[fx][fy]=='.'){
            dfs(fx,fy);
            ans++;
        }
    }
}

int main (){
    int i,j,sx,sy;
    while(scanf("%d%d",&n,&m),n,m){
        for(i=0;i<m;++i){
            scanf("%s",map[i]);
            for(j=0;j<n;++j){
                if(map[i][j]=='@'){
                    sx=i,sy=j;
                }
            }
        }
    ans=0;
    dfs(sx,sy);
    printf("%d\n",ans+1);
    }
    return 0;
}