天天看點

poj 1836 Alignment

Alignment
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 15913 Accepted: 5195

Description

In the army, a platoon is composed by n soldiers. During the morning inspection, the soldiers are aligned in a straight line in front of the captain. The captain is not satisfied with the way his soldiers are aligned; it is true that the soldiers are aligned in order by their code number: 1 , 2 , 3 , . . . , n , but they are not aligned by their height. The captain asks some soldiers to get out of the line, as the soldiers that remain in the line, without changing their places, but getting closer, to form a new line, where each soldier can see by looking lengthwise the line at least one of the line's extremity (left or right). A soldier see an extremity if there isn't any soldiers with a higher or equal height than his height between him and that extremity. 

Write a program that, knowing the height of each soldier, determines the minimum number of soldiers which have to get out of line. 

Input

On the first line of the input is written the number of the soldiers n. On the second line is written a series of n floating numbers with at most 5 digits precision and separated by a space character. The k-th number from this line represents the height of the soldier who has the code k (1 <= k <= n). 

There are some restrictions: 

• 2 <= n <= 1000 

• the height are floating numbers from the interval [0.5, 2.5] 

Output

The only line of output will contain the number of the soldiers who have to get out of the line.

Sample Input

8
1.86 1.86 1.30621 2 1.4 1 1.97 2.2
      
Sample Output
4      

Source

Romania OI 2002

提示

題意:

一位長官想讓士兵們站成新的一排,身高以最高的為基準,每個人的身高從左到右是遞減,從右到左也是遞減,類似于正态分布(個子最高的不一定在最中間):

poj 1836 Alignment

問至少要幾個人出隊才能使這一排達到要求?

思路:

左邊的身高是從小到大遞增,右邊是從大到小,那麼我們這樣想,用DP求出最大上升子序列和最大下降子序列相加,再減去人的數量不就是最少出隊的人數麼。

求最大上升子序列從隊頭開始,最大下降子序列從隊尾開始,這點要注意一下。

示例程式

Source Code

Problem: 1836		Code Length: 835B
Memory: 396K		Time: 63MS
Language: GCC		Result: Accepted
#include <stdio.h>
int main()
{
    int n,i,i1,dp[2][1000],max=0;		//dp[0][]記錄最長遞增序列,dp[1][]記錄最長遞減序列
    double a[1000];
    scanf("%d",&n);
    for(i=0;n>i;i++)
    {
        scanf("%lf",&a[i]);
        dp[0][i]=1;				//最少遞增或遞減有1個
        dp[1][i]=1;
    }
    for(i=1;n>i;i++)				//從左到右的最長遞增序列
    {
        for(i1=0;i>i1;i1++)
        {
            if(a[i]>a[i1]&&dp[0][i1]+1>dp[0][i])
            {
                dp[0][i]=dp[0][i1]+1;
            }
        }
    }
    for(i=n-2;i>=0;i--)				//從右到左的最長遞減序列
    {
        for(i1=i+1;n>i1;i1++)
        {
            if(a[i]>a[i1]&&dp[1][i1]+1>dp[1][i])
            {
                dp[1][i]=dp[1][i1]+1;
            }
        }
    }
    for(i=0;i<n;i++)
    {
        for(i1=i+1;i1<n;i1++)			//最長遞增序列向後一個數尋找最長的遞減序列
        {
            if(dp[0][i]+dp[1][i1]>max)
            {
                max=dp[0][i]+dp[1][i1];
            }
        }
    }
    printf("%d",n-max);
    return 0;
}