天天看點

POJ 1985 Cow Marathon(牛的鍛煉,樹的直徑)

Cow Marathon

Time Limit: 2000MS Memory Limit: 30000K
Total Submissions: 5000 Accepted: 2429
Case Time Limit: 1000MS

Description

After hearing about the epidemic of obesity in the USA, Farmer John wants his cows to get more exercise, so he has committed to create a bovine marathon for his cows to run. The marathon route will include a pair of farms and a path comprised of a sequence of roads between them. Since FJ wants the cows to get as much exercise as possible he wants to find the two farms on his map that are the farthest apart from each other (distance being measured in terms of total length of road on the path between the two farms). Help him determine the distances between this farthest pair of farms. 

Input

* Lines 1.....: Same input format as "Navigation Nightmare".

Output

* Line 1: An integer giving the distance between the farthest pair of farms. 

Sample Input

7 6
1 6 13 E
6 3 9 E
3 5 7 S
4 1 3 N
2 4 20 W
4 7 2 S
      

Sample Output

52
      

Hint

The longest marathon runs from farm 2 via roads 4, 1, 6 and 3 to farm 5 and is of length 20+3+13+9+7=52. 

Source

USACO 2004 February

題意:

和 POJ 2631(點選檢視) 差不多。這題目的大意就是,多讓牛鍛煉,保護好身體,不生病。

也就是給一些邊,問哪兩個節點的距離最大。

思路:

樹的最大直徑,相當于模闆題,做了2631,這個就挺簡單的了!

代碼:

#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
const int MYDD=110300;

int edgenum;//邊的數目
int head[MYDD];//節點頭指針
void init_edge() {
	edgenum=0;
	memset(head,-1,sizeof(head));
}

struct EDGE { //邊的資訊
	int u,v,w,next;
} edge[MYDD*2];
void addedge(int u,int v,int w) {//增加邊資訊
	EDGE Edge= {u,v,w,head[u]};//可以學習這種方法指派
	edge[edgenum]=Edge;
	head[u]=edgenum++;
}

bool vis[MYDD];//記錄節點的通路狀态
int dis[MYDD];//記錄節點所在直徑的最大值
int Tnode,ans;
void BFS(int sx) {
	queue<int> Q;
	memset(vis,false,sizeof(vis));
	memset(dis,0,sizeof(dis));
	vis[sx]=true;
	Q.push(sx);
	Tnode=sx;
	ans=0;
	while(!Q.empty()) {
		int first=Q.front();
		Q.pop();
		for(int j=head[first]; j!=-1; j=edge[j].next) {
			int v=edge[j].v;
			if(!vis[v]) {
				if(dis[v]<edge[j].w+dis[first]) {
					dis[v]=edge[j].w+dis[first];
				}
				vis[v]=true;
				Q.push(v);
				if(ans<dis[v]) {
					ans=dis[v];
					Tnode=v;
				}
			}
		}
	}
}

int main() {
	int n,m;
	while(scanf("%d%d",&n,&m)!=EOF) {
		init_edge();
		while(m--) {
			int u,v,w;
			char dd[4];
			scanf("%d%d%d%s",&u,&v,&w,dd);
			addedge(u,v,w);
			addedge(v,u,w);//再寫成 u,v,w 試試 
		}
		BFS(1);
		BFS(Tnode);
		printf("%d\n",ans);
	}
}
           

後:

**************

POJ 1985 Cow Marathon(牛的鍛煉,樹的直徑)
poj