天天看點

PAT甲級A1065 A+B and C (64bit) (20 分)

Given three integers A, B and C in [−2​63​​,2​63​​], you are supposed to tell whether A+B>C.

Input Specification:

The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line

Case #X: true

if A+B>C, or

Case #X: false

otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0
           

Sample Output:

Case #1: false
Case #2: true
Case #3: false
           

題意:給出三個64位的數字,讓你判斷 a+b與c的大小關系

思路:使用long long 類型存儲數字。a+b的結果一定要存儲在一個long long類型的變量中,不能直接用a+b與c比較大小。

注意邊界,若a>0,b>0且a+b<=0則說明越界了,反之也是。

參考代碼:

#include<cstdio>
using namespace std;
int main()
{
	int n;
	long long a,b,c,d;
	scanf("%d",&n);
	for(int i=1;i<=n;i++){
		scanf("%lld %lld %lld",&a,&b,&c);
		d=a+b;
		if(a>0&&b>0&&d<=0)
			printf("Case #%d: true\n",i);
		else if (a<0&&b<0&&d>=0)
			printf("Case #%d: false\n",i);
		else if(d>c) 
			printf("Case #%d: true\n",i);
		else 
			printf("Case #%d: false\n",i);
	}
	return 0;
}