天天看點

PAT甲級 -- 1007 Maximum Subsequence Sum (25 分)

Given a sequence of K integers { N​1​​, N​2​​, ..., N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, ..., N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains Knumbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21
           

Sample Output:

10 1 4
           

9分:

跑出來結果也沒問題,PAT不給測試樣例,不知道自己出錯在哪...

#include <iostream>
#include <cmath>
using namespace std;

const int maxn = 10010;
int k; //k個元素
int a[maxn]; //存放序列
int dp[maxn]; //以a[i]結尾的最大和

struct node
{
	int start, end;
}index[maxn];

int count_negative = 0, count_0 = 0;


int main()
{
	scanf("%d", &k);
	for(int i = 0; i < k; i++)
	{
		scanf("%d", &a[i]);
		if(a[i] < 0) count_negative++;
		else if(a[i] == 0) count_0++;
	}

	dp[0] = a[0];
	index[0].start = 0, index[0].end = 0;
	for(int i = 1; i < k; i++)
	{
		if (dp[i-1] + a[i] >= a[i])
		{
			dp[i] = dp[i-1] + a[i];
			index[i].start = index[i-1].start, index[i].end = i;
		}else
		{
			dp[i] = a[i];
			index[i].start = i, index[i].end = i;
		}
	}
	int j = 0;
	for(int i = 1; i < k; i++)
	{
		if(dp[i] > dp[j])
		{
			j = i;
		}else if(dp[j] == dp[i])
		{
			if(index[j].start == index[i].start)
			{
				if(index[j].end > index[i].end)
				{
					j = i;
				}
			}else if(index[j].start > index[i].start)
			{
				j = i;
			}
		}
	}

	if(dp[j] <= 0)
	{
		if(count_negative == k)
		{
			printf("0 %d %d", a[0], a[k-1]);
		}else if(count_negative + count_0 == k)
		{
			printf("0 0 0");
		}
	}else
	{
		printf("%d %d %d", dp[j], index[j].start, index[j].end);
	}

	
	return 0;
}
           

正确code:

看了部落客的答案,還是沒看出來差别在哪,求告知啊啊啊啊!!!

#include<iostream>
using namespace std;
int main()
{
	int N;
	cin>>N;
	int in[N];
	int result[N];
	int dp[N];
	for(int i=0;i<N;++i)
		cin>>in[i];
	dp[0]=max(in[0],0);         //動态規劃,初始狀态定義
	for(int i=1;i<N;++i){        
		if(dp[i-1]+in[i] < 0)
			dp[i]=max(in[i],0);
		else
			dp[i]=dp[i-1]+in[i];
	}
    //至此,dp(dynamic programming)數組結束
 
	int maxid=0;
	for(int i=0;i<N;++i)   //這個循環:找最大的序列和
	{
		if(dp[i]>dp[maxid])
			maxid=i;
	}
	if(dp[maxid]>0){
		int temp=maxid;
		int i=0;
		while(dp[temp]>0){
			result[i]=in[temp];
			--temp;
			++i;
		}
		cout<<dp[maxid]<<" "<<result[i-1]<<" "<<result[0]<<endl;
	}
	else{
		int j;
		for(j=0;j<N;++j)
		{
			if(in[j]==0)	
				break;
		}
		if(j<N-1||in[N-1]==0)
			cout<<"0 0 0"<<endl;
		else
			cout<<"0 "<<in[0]<<" "<<in[N-1]<<endl;
	}
	return 0;
}
--------------------- 
作者:天啊野 
來源:CSDN 
原文:https://blog.csdn.net/weixin_38097576/article/details/82715413 
版權聲明:本文為部落客原創文章,轉載請附上博文連結!