天天看點

HDU1072-Nightmare【廣度優先搜尋】

Nightmare

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 7069    Accepted Submission(s): 3397

Problem Description

Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius' start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:

1. We can assume the labyrinth is a 2 array.

2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.

3. If Ignatius get to the exit when the exploding time turns to 0, he can't get out of the labyrinth.

4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can't use the equipment to reset the bomb.

5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.

6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.

There are five integers which indicate the different type of area in the labyrinth:

0: The area is a wall, Ignatius should not walk on it.

1: The area contains nothing, Ignatius can walk on it.

2: Ignatius' start position, Ignatius starts his escape from this position.

3: The exit of the labyrinth, Ignatius' target position.

4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.

Output

For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.

Sample Input

3

3 3

2 1 1

1 1 0

1 1 3

4 8

2 1 1 0 1 1 1 0

1 0 4 1 1 0 4 1

1 0 0 0 0 0 0 1

1 1 1 4 1 1 1 3

5 8

1 2 1 1 1 1 1 4

1 0 0 0 1 0 0 1

1 4 1 0 1 1 0 1

1 0 0 0 0 3 0 1

1 1 4 1 1 1 1 1

Sample Output

4

-1

13

Author

Ignatius.L

//廣度優先周遊......

具體參看http://blog.csdn.net/acmman/article/details/38342115

(第一次寫廣搜,代碼參考了HDU的讨論區)

#include<cstdio>
#include<iostream>
#include<queue>
#define N 10
using namespace std;
int map[N][N],n,m;
int dir[4][2]=
{
    {0,1},  /*向右*/
    {0,-1}, /*向左*/
 {-1,0},  /*向下*/
 {1,0}  /*向上*/
};
struct Node
{
   int x,y;//記錄坐标 
   int step,time;//步數和時間 
}start;
void BFS()
{
   queue<Node>q;//隊列實作
   Node q1,q2;//交換值,相當于temp 
   q.push(start);//将start放入隊列
   
   //隊列為空時說明 1.已經掃描到結果
   //2.完全掃描結束(沒找到結果)
   while(!q.empty())
   {
      int i;
      q1=q.front();//将隊頭的資料拿出來
      q.pop();//将隊頭彈出
      //開始搜尋上下左右四個方向 
      for(i=0;i<4;i++)
      {
         q2.x=q1.x+dir[i][0];
         q2.y=q1.y+dir[i][1];
         q2.step=q1.step+1;
         q2.time=q1.time-1;
         //判斷走這一步是否已經超出矩陣範圍 
          //确定此步不是走過的(或牆)或者炸彈時間已到 
         if(q2.x>=0&&q2.y>=0&&q2.x<n&&q2.y<m&&map[q2.x][q2.y]!=0&&q2.time>0)
         {
            //說明找到答案,結束搜尋 
            if(map[q2.x][q2.y]==3)
            {
               printf("%d\n",q2.step);
               return;                    
            }
            else if(map[q2.x][q2.y]==4)
            {//碰到時間調整器,可以恢複時間 
                 q2.time=6;
                 map[q2.x][q2.y]=0; //标記已經走過   
            }  
            q.push(q2);//将這一步放進隊列                               
         }
      } 
   }  
   //隊列掃完都沒搜到答案,說明答案不存在
   printf("-1\n");
   return;
}
int main()
{
    int i,j,T;
    scanf("%d",&T);
    while(T--)
    {
       scanf("%d %d",&n,&m);
       for(i=0;i<n;i++)
         for(j=0;j<m;j++)
         {
            scanf("%d",&map[i][j]);
            if(map[i][j]==2)
            {
               start.x=i;
               start.y=j;
               start.step=0;
               start.time=6;//時間初始化為6 
            }
         }
         BFS(); 
    }
    return 0;
}