Babelfish
Description
You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.
Input
Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.
Output
Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".
Sample Input
dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay
atcay
ittenkay
oopslay
Sample Output
cat
eh
loops
#include<iostream>
#include<string>
#include<string.h>
#include<map>
using namespace std;
map<string,string> dic;
map<string,string>::iterator it;
int main()
{
string s,x;
char c;
while(c=getchar())//判斷第一個字元,如果是回車就停止
{
if(c==10) break;
cin>>s;s=c+s;
cin>>x;
c=getchar();//讀取行尾回車
dic.insert(make_pair(x,s));//将兩個string串儲存到map容器裡
}
while(cin>>s)
{
it=dic.find(s);//從容器中查找與之比對的串
if(it==dic.end()) cout<<"eh"<<endl;
else{
x=it->second;
cout<<x<<endl;
}
}
return 0;
}