天天看点

poj2503 Babelfish(STL-map)

Babelfish

Description

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

Input

Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.

Output

Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".

Sample Input

dog ogday

cat atcay

pig igpay

froot ootfray

loops oopslay

atcay

ittenkay

oopslay

Sample Output

cat

eh

loops

#include<iostream>
#include<string>
#include<string.h>
#include<map>
using namespace std;
map<string,string> dic;
map<string,string>::iterator it;
int main()
{
	string s,x;
	char c;
	while(c=getchar())//判断第一个字符,如果是回车就停止
	{
		if(c==10) break;
		cin>>s;s=c+s;
		cin>>x;
		c=getchar();//读取行尾回车
		dic.insert(make_pair(x,s));//将两个string串保存到map容器里
	}
	while(cin>>s)
	{
		it=dic.find(s);//从容器中查找与之匹配的串
		if(it==dic.end()) cout<<"eh"<<endl;
		else{
			x=it->second;
			cout<<x<<endl;
		}
	}
	return 0;
}
           
STL