天天看点

ZOJ 3804 YY's Minions

Description

Despite YY's so much homework, she would like to take some time to play with her minions first.

YY lines her minions up to an N*M matrix. Every minion has two statuses: awake or asleep. We use 0(the digit) to represent that it is asleep, and 1 for awake. Also, we define the minions who are around a minion closest in one of the eight directions its neighbors. And every minute every minion will change its status by the following specific rules:

  • If this minion is awake, and the number of its neighbors who are awake is less than 2, this minion will feel lonely and turn to asleep.
  • If this minion is awake, and the number of its neighbors who are awake is more than 3, this minion will turn to asleep for it will feel too crowded.
  • If this minion is awake, and the number of its neighbors who are awake is exactly 2 or 3, this minion will keep being awake and feel very happy.
  • If this minion is asleep, and the number of its neighbors who are awake is exactly 3, this minion will wake up because of the noise.Note that all changes take place at the same time at the beginning of a specific minute.

    Also, some minions will get bored and leave this silly game. We use 'X's to describe them. We suppose that a minion would leave after Tminutes. It will leave at the end of the Tth minute. Its status is considered during the change at the beginning of the Tth minute, and should be ignored after that. Of course, one minion will not leave twice!

    YY is a girl full of curiosity and wants to know every minion's status after F

Input

There are multiple test cases.

The first line contains the number of test cases Q. 1<=Q<=100.

For each case, there are several lines:

The first line contains four integers N, M, F, K. K means the number of leaving messages. 1<=N, M<=50, 1<=F<=1000, 1<=K<=N*M. 

Next N lines are the matrix which shows the initial status of each minion. Each line contains M chars. We guarantee that 'X' wouldn't appear in initial status matrix. 

And next K lines are the leaving messages. Each line contains three integers Ti, Xi, Yi, They mean the minion who is located in (Xi, Yi) will leave the game at the end of the Tith minutes. 1<=Ti<= F, 1<=Xi<=N, 1<=Yi<=M.

Output

For each case, output N lines as a matrix which shows the status of each minion after F

Sample Input

2

3 3 2 1

101

110

001

1 2 2

5 5 6 3

10111

01000

00000

01100

10000

2 3 3

2 4 1

5 1 5

Sample Output

010

1X0

010

0000X

11000

00X00

X0000

00000

Hint

For case 1:

T=0, the game starts

101

110

001

---------------

at the beginning of T=1, a change took place

100

101

010

---------------

at the end of T=1 (the minion in (2,2) left)

100

1X1

010

---------------

at the beginning of T=2, a change took place

010

1X0

010

---------------

at the end of T=2 (nothing changed for no minion left at T=2)

010

1X0

010

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
const int maxn=52;
int x,y,T,n,m,t,p,F,f[1001][maxn][maxn];
int a[8]={-1,-1,-1,0,0,1,1,1};
int b[8]={-1,0,1,-1,1,-1,0,1};
char c[1000];

int check(int u,int x,int y)
{
  int sum=0;
  for (int i=0;i<8;i++)
    if (f[u][x+a[i]][y+b[i]]==1) sum++;
  return sum;
}

void work(int x)
{
  for (int i=1;i<=n;i++)
    for (int j=1;j<=m;j++)
      if (f[x-1][i][j]>=0&&f[x][i][j]!=-1)
      {
        int y=check(x-1,i,j);
        if (y==3&&f[x-1][i][j]==0) f[x][i][j]=1;
        else 
          if (f[x-1][i][j]==1&&(y>3||y<2)) f[x][i][j]=0;
          else f[x][i][j]=f[x-1][i][j];
      }
      else f[x][i][j]=-1;
}

int main()
{
  cin>>T;
  while (T--)
  {
    memset(f,0,sizeof(f));
    cin>>n>>m>>F>>p;
    for (int i=1;i<=n;i++)
    {
      scanf("%s",c);
      for (int j=1;j<=m;j++) f[0][i][j]=c[j-1]-'0';
    }
    while (p--)
    {
      scanf("%d%d%d",&t,&x,&y);
      for (int i=t;i<=F;i++) f[i][x][y]=-1;
    }
    for (int i=1;i<=F;i++) work(i);
    for (int i=1;i<=n;i++)
    {
      for (int j=1;j<=m;j++)
        if (f[F][i][j]>=0) printf("%d",f[F][i][j]);
        else printf("X");
      printf("\n");
    }
  }
  return 0;
}