天天看点

HDU 1264 Counting Squares

Problem Description

Your input is a series of rectangles, one per line. Each rectangle is specified as two points(X,Y) that specify the opposite corners of a rectangle. All coordinates will be integers in the range 0 to 100. For example, the line

5 8 7 10

specifies the rectangle who's corners are(5,8),(7,8),(7,10),(5,10).

If drawn on graph paper, that rectangle would cover four squares. Your job is to count the number of unit(i.e.,1*1) squares that are covered by any one of the rectangles given as input. Any square covered by more than one rectangle should only be counted once.

Input

The input format is a series of lines, each containing 4 integers. Four -1's are used to separate problems, and four -2's are used to end the last problem. Otherwise, the numbers are the x-ycoordinates of two points that are opposite corners of a rectangle.

Output

Your output should be the number of squares covered by each set of rectangles. Each number should be printed on a separate line.

Sample Input

5 8 7 10

6 9 7 8

6 8 8 11

-1 -1 -1 -1

0 0 100 100

50 75 12 90

39 42 57 73

-2 -2 -2 -2

Sample Output

8

10000

#include<iostream>  
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<string>
using namespace std;
const int maxn = 101;
int x1, x2, Y1, Y2, f[maxn*maxn] = { 0 };

int find()
{
  int tot = 0;
  for (int i = 0; i < maxn*maxn; f[i] = 0, i++) tot += f[i];
  return tot;
}

int main(){
  while (~scanf("%d%d%d%d", &x1, &Y1, &x2, &Y2))
  {
    if (x1 < 0) { cout << find() << endl; continue; }
    for (int i = min(x1, x2); max(x1, x2) - i; i++)
      for (int j = min(Y1, Y2); max(Y1, Y2) - j; j++) f[i*maxn + j] = 1;
  }
  return 0;
}