天天看点

HDU 2087 剪花布条

Problem Description

一块花布条,里面有些图案,另有一块直接可用的小饰条,里面也有一些图案。对于给定的花布条和小饰条,计算一下能从花布条中尽可能剪出几块小饰条来呢?

Input

输入中含有一些数据,分别是成对出现的花布条和小饰条,其布条都是用可见ASCII字符表示的,可见的ASCII字符有多少个,布条的花纹也有多少种花样。花纹条和小饰条不会超过1000个字符长。如果遇见#字符,则不再进行工作。

Output

输出能从花纹布中剪出的最多小饰条个数,如果一块都没有,那就老老实实输出0,每个结果之间应换行。

Sample Input

abcde a3

aaaaaa aa

#

Sample Output

3

#include<cstdio>
#include<iostream>
#include<vector>
#include<algorithm>
#include<string>
#include<cstring>
using namespace std;
const int maxn = 500005;
int nt[maxn], tot, x;
char s[maxn], S[maxn];

int main()
{
  while (scanf("%s", S) && S[0] != '#')
  {
    scanf("%s", s);
    nt[0] = x = -1;
    for (int i = tot = 0; s[i]; i++)
    {
      int k = nt[i];
      while (k >= 0 && s[i] != s[k]) k = nt[k];
      nt[i + 1] = k + 1;
    }
    for (int i = 0, j = nt[1]; S[i];)
    {
      if (j < 0 || S[i] == s[j])
      {
        i++, j++;
        if (!s[j] && i - j > x){ x = i - 1; tot++; }
      }
      else j = nt[j];
    }
    printf("%d\n", tot);
  }
  return 0;
}