天天看点

LightOJ 1225 Palindromic Numbers

Description

A palindromic number or numeral palindrome is a 'symmetrical' number like 16461, that remains the same when its digits are reversed. In this problem you will be given an integer, you have to say whether the number is a palindromic number or not.

Input

Input starts with an integer T (≤ 20000), denoting the number of test cases.

Each case starts with a line containing an integer n (0 ≤ n < 109).

Output

For each case, print the case number and 'Yes' if n is palindromic, otherwise print 'No'.

Sample Input

5

1

21

16161

523125

Sample Output

Case 1: Yes

Case 2: No

Case 3: Yes

Case 4: No

Case 5: Yes

#include<stdio.h>
#include<iostream>
#include<math.h>
#include<string.h>
#include<algorithm>
#define ll long long
#define IT acos(-1.0)
using namespace std;
int main()
{  int t,m=1,n,k,ans;
char s[10000];
   scanf("%d",&t);
    while(t--)
   {scanf("%s",s);
   n=strlen(s);
   k=0;
   for(int i=0;i<n/2;i++)
   {if(s[i]!=s[n-i-1])
     {  k=1;
        break;
     }
   }
   if(k==1)
   printf("Case %d: No\n",m++);
    else
   printf("Case %d: Yes\n",m++); 
   }
}