天天看点

杭电 2147 kiki‘s game  

Problem Description Recently kiki has nothing to do. While she is bored, an idea appears in his mind, she just playes the checkerboard game.The size of the chesserboard is n*m.First of all, a coin is placed in the top right corner(1,m). Each time one people can move the coin into the left, the underneath or the left-underneath blank space.The person who can't make a move will lose the game. kiki plays it with ZZ.The game always starts with kiki. If both play perfectly, who will win the game?

Input Input contains multiple test cases. Each line contains two integer n, m (0<n,m<=2000). The input is terminated when n=0 and m=0.

Output If kiki wins the game printf "Wonderful!", else "What a pity!".

Sample Input

5 3
5 4
6 6
0 0
        

Sample Output

What a pity!
Wonderful!
Wonderful!
  
  
    
  
  
    
  
  
      简单的博弈题目   只有当全是奇数的时候才失败,一开始考录的太复杂   情况太多 最后发现居然这么简单
  
  
    
  
  
   已AC代码:
  
  
          
#include<stdio.h>
int main()
{
	int m,n;
	while(scanf("%d%d",&m,&n),m,n)
	{
		if(m%2==1&&n%2==1)
		printf("What a pity!\n");
		else
		printf("Wonderful!\n");
	}
	return 0;
}