天天看点

杭电 2057 A + B Again

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2057

Problem Description

There must be many A + B problems in our HDOJ , now a new one is coming.

Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too.

Easy ? AC it !

Input

The input contains several test cases, please process to the end of the file.

Each case consists of two hexadecimal integers A and B in a line seperated by a blank.

The length of A and B is less than 15.

Output

For each test case,print the sum of A and B in hexadecimal in one line.

Sample Input

+A -A

+1A 12

1A -9

-1A -12

1A -AA

Sample Output

2C

11

-2C

-90

其实就是十六进制的加减。不过以前没遇到过这么大的

#include<iostream>
#include<sstream>
#include<cstring>
#include<algorithm>
#include<set>
#include<cstdio>
using namespace std;
int main(){
    __int64 a,b;
    while(scanf("%I64X %I64X",&a,&b)!=EOF){
        if(a+b>=){
            printf("%I64X\n",a+b);
        }
        else{   //第一次用到这么大的数据类型,很奇怪,为负数时非要这么写  路过的大佬方便的话解个答 
            printf("-%I64X\n",-a-b);//这里的x要大写,这样结果输出的格式才会大写 
        }
    } 
    return ;
}
           

继续阅读