天天看點

杭電 2057 A + B Again

題目連結:http://acm.hdu.edu.cn/showproblem.php?pid=2057

Problem Description

There must be many A + B problems in our HDOJ , now a new one is coming.

Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too.

Easy ? AC it !

Input

The input contains several test cases, please process to the end of the file.

Each case consists of two hexadecimal integers A and B in a line seperated by a blank.

The length of A and B is less than 15.

Output

For each test case,print the sum of A and B in hexadecimal in one line.

Sample Input

+A -A

+1A 12

1A -9

-1A -12

1A -AA

Sample Output

2C

11

-2C

-90

其實就是十六進制的加減。不過以前沒遇到過這麼大的

#include<iostream>
#include<sstream>
#include<cstring>
#include<algorithm>
#include<set>
#include<cstdio>
using namespace std;
int main(){
    __int64 a,b;
    while(scanf("%I64X %I64X",&a,&b)!=EOF){
        if(a+b>=){
            printf("%I64X\n",a+b);
        }
        else{   //第一次用到這麼大的資料類型,很奇怪,為負數時非要這麼寫  路過的大佬友善的話解個答 
            printf("-%I64X\n",-a-b);//這裡的x要大寫,這樣結果輸出的格式才會大寫 
        }
    } 
    return ;
}
           

繼續閱讀