天天看点

HDU 4722-Good Numbers

Description

If we sum up every digit of a number and the result can be exactly divided by 10, we say this number is a good number.

You are required to count the number of good numbers in the range from A to B, inclusive.  

Input

The first line has a number T (T <= 10000) , indicating the number of test cases.

Each test case comes with a single line with two numbers A and B (0 <= A <= B <= 10 18).  

Output

For test case X, output "Case #X: " first, then output the number of good numbers in a single line.  

Sample Input

2
1 10
1 20 
          

Sample Output

Case #1: 0
Case #2: 1 
          

Hint

The answer maybe very large, we recommend you to use long long instead of int.       

打表找规律~

发现每100位便可以找到10各个位置加起来是10的倍数的数字...只要判断a 和b 是100的几倍即可~~

CODE:

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<string>
using namespace std;

int main()
{
    int T;
    scanf("%d",&T);
    for(int tt=1;tt<=T;tt++)
    {
        long long a,b;
        scanf("%I64d%I64d",&a,&b);
        long long ans=(b/100-a/100)*10;
        long long aa=a/100*100;
        while(aa<a)
        {//printf("1\n");
            long long ta=aa;
            long long t=0;
            while(ta!=0)
            {
                t+=ta%10;
                ta=ta/10;
            }
            if(t%10==0)
            {
                ans--;
            }
            aa++;
        }
        long long bb=b/100*100;
        while(bb<=b)
        {//printf("1\n");
            long long tb=bb;
            long long t=0;
            while(tb!=0)
            {
                t+=tb%10;
                tb=tb/10;
            }
            if(t%10==0)
            {
                ans++;
            }
            bb++;
        }
        printf("Case #%d: %I64d\n",tt,ans);
    }
    return 0;
}