天天看点

HiHocoder #1136 : Professor Q's Software 微软2016校园招聘在线笔试 【拓扑排序+DP】

#1136 : Professor Q's Software

时间限制: 10000ms 单点时限: 1000ms 内存限制: 256MB

描述

Professor Q develops a new software. The software consists of N modules which are numbered from 1 to N. The i-th module will be started up by signal Si. If signal Si is generated multiple times, the i-th module will also be started multiple times. Two different modules may be started up by the same signal. During its lifecircle, the i-th module will generate Ki signals: E1, E2, ..., EKi. These signals may start up other modules and so on. Fortunately the software is so carefully designed that there is no loop in the starting chain of modules, which means eventually all the modules will be stoped. Professor Q generates some initial signals and want to know how many times each module is started.
HiHocoder #1136 : Professor Q's Software 微软2016校园招聘在线笔试 【拓扑排序+DP】

输入

The first line contains an integer T, the number of test cases. T test cases follows.

For each test case, the first line contains contains two numbers N and M, indicating the number of modules and number of signals that Professor Q generates initially.

The second line contains M integers, indicating the signals that Professor Q generates initially.

Line 3~N + 2, each line describes an module, following the format S, K, E1, E2, ... , EK. S represents the signal that start up this module. K represents the total amount of signals that are generated during the lifecircle of this module. And E1 ... EK are these signals.

For 20% data, all N, M <= 10

For 40% data, all N, M <= 103

For 100% data, all 1 <= T <= 5, N, M <= 105, 0 <= K <= 3, 0 <= S, E <= 105.

Hint: HUGE input in this problem. Fast IO such as scanf and BufferedReader are recommended.

输出

For each test case, output a line with N numbers Ans1, Ans2, ... , AnsN. Ansi is the number of times that the i-th module is started. In case the answers may be too large, output the answers modulo 142857 (the remainder of division by 142857).

样例输入

3
3 2
123 256
123 2 456 256
456 3 666 111 256
256 1 90
3 1
100
100 2 200 200
200 1 300
200 0
5 1
1
1 2 2 3
2 2 3 4
3 2 4 5
4 2 5 6
5 2 6 7      
样例输出
1 1 3
1 2 2
1 1 2 3 5      

思路:

将信号离散化---然后对每个信号进行拓扑排序---

然后就可以得到一个按信号传递方向的拓扑序列---

最后按序DP即可--------

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#include<map>
using namespace std;
int n,m,ans,kai[100100];//拓扑+dp
int ru[100100],head[100100],he[100100],dp[100100];
bool fafe[100100];
struct node{
    int to,next;
}egde[200100],hui[200100];
void ADD(int a,int b,int x)
{
    egde[x].to=b;
    egde[x].next=head[a];
    head[a]=x;
}
void AD(int a,int b,int x)
{
    hui[x].to=b;
    hui[x].next=he[a];
    he[a]=x;
}
void slove()
{
    int n,m;
    scanf("%d%d",&n,&m);
    memset(dp,0,sizeof(dp));
    memset(fafe,false,sizeof(fafe));
    memset(ru,0,sizeof(ru));
    map <int ,int  > hao;
    map <int ,int  > dian;
    for (int i=0;i<m;i++)
        scanf("%d",&kai[i]);
    for (int i=0;i<100010;i++)
    {
        head[i]=-1;
        he[i]=-1;
    }
    int kp=1,lp=1,q,a,b;
    for (int i=1;i<=n;i++)
    {
        scanf("%d%d",&a,&q);
        if (!hao[a])
            hao[a]=kp++;
        int dd=hao[a],ff;
        dian[i]=dd;//map一下序号
        while (q--)
        {
            scanf("%d",&b);
            if (!hao[b])
                hao[b]=kp++;
            ff=hao[b];
            ru[ff]++;
            AD(dd,ff,lp);//拓扑边
            ADD(ff,dd,lp++);//DP边
        }
    }
    for (int i=0;i<m;i++)
        if (hao[kai[i]])
    {
        int dd=hao[kai[i]];
        dp[dd]++;
    }
    queue<int > que;
    bool opop;
    while (1)//拓扑排序
    {
        opop=true;
        for (int i=1;i<kp;i++)
        if (!fafe[i]&&ru[i]==0)
        {
            opop=false;
            que.push(i);
            fafe[i]=true;
            for (int j=he[i];j!=-1;j=hui[j].next)
            {
                ru[hui[j].to]--;
            }
        }
        if (opop) break;
    }
    int x,y;
    while (!que.empty())//按顺序DP
    {
        int x=que.front();
        que.pop();
        for (int i=head[x];i!=-1;i=egde[i].next)
        {
            dp[x]+=dp[egde[i].to];
        }
    }

    for (int i=1;i<n;i++)
        printf("%d ",dp[dian[i]]);
    printf("%d\n",dp[dian[n]]);
}
int main()
{
    int t;scanf("%d",&t);
    while (t--)
    {
        slove();
    }
    return 0;
}