天天看点

Central Europe 1996 / UVa 311 / POJ 1017 Packets (贪心)

311 - Packets

Time limit: 3.000 seconds 

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=113&page=show_problem&problem=247

http://poj.org/problem?id=1017

A factory produces products packed in square packets of the same height h and of the sizes

Central Europe 1996 / UVa 311 / POJ 1017 Packets (贪心)

,

Central Europe 1996 / UVa 311 / POJ 1017 Packets (贪心)

,

Central Europe 1996 / UVa 311 / POJ 1017 Packets (贪心)

,

Central Europe 1996 / UVa 311 / POJ 1017 Packets (贪心)

,

Central Europe 1996 / UVa 311 / POJ 1017 Packets (贪心)

,

Central Europe 1996 / UVa 311 / POJ 1017 Packets (贪心)

. These products are always delivered to customers in the square parcels of the same heighth as the products have and of the size

Central Europe 1996 / UVa 311 / POJ 1017 Packets (贪心)

. Because of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.

Input

The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size

Central Europe 1996 / UVa 311 / POJ 1017 Packets (贪心)

to the biggest size

Central Europe 1996 / UVa 311 / POJ 1017 Packets (贪心)

. The end of the input file is indicated by the line containing six zeros.

Output

The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last ``null'' line of the input file.

Sample Input

0 0 4 0 0 1
7 5 1 0 0 0
0 0 0 0 0 0      

Sample Output

2
1      

简单贪心,采用偏差修正的方法AC。

完整代码:

/*0.016s*/

#include <cstdio>

int main()
{
	int a, b, c, d, e, f, ans;
	while (scanf("%d%d%d%d%d%d", &a, &b, &c, &d, &e, &f), a || b || c || d || e || f)
	{
		ans = f + e + d + c / 4 + (c % 4 == 0 ? 0 : 1);///至少要这么多
		a -= 11 * e, b -= 5 * d;///尽管减,就算<0也没关系
		switch (c % 4)
		{
			case 3: a -= 5, b -= 1; break;
			case 2: a -= 6, b -= 3; break;
			case 1: a -= 7, b -= 5; break;
		}
		if (b < 0)///偏差修正
		{
			a += b * 4;
			b = 0;
		}
		ans += b / 9 + (b % 9 == 0 ? 0 : 1);///补遗
		if (b % 9) a -= 36 - (b % 9 * 4);
		if (a > 0) ans += a / 36 + (a % 36 == 0 ? 0 : 1);///补遗
		printf("%d\n", ans);
	}
	return 0;
}