天天看点

POJ3624解题报告

Charm Bracelet

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7247 Accepted: 3278

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7      

Sample Output

23      
题意:给定每个物品的重量和价值,求给定最大重量下能获得的最大价值。。      
我的背包第一题      
思路:01背包,状态方程为dp[i][j]=MAX(dp[i-1][j],dp[i-1][j-weight[i]]+value[i])      
#include<iostream>
using namespace std;
int N,W,weight[40000],cost[40000],dp[40000],i,j;

int main()
{
	while(cin>>N>>W&&N)
	{
		for(i=0;i<N;i++)
			cin>>cost[i]>>weight[i];
		memset(dp,0,sizeof(dp));
		
		for(i=0;i<N;i++)
			for(j=W;j>=cost[i];j--)
			{
				if(j-cost[i]>=0)
				{
					if(dp[j-cost[i]]+weight[i]>dp[j])
						dp[j]=dp[j-cost[i]]+weight[i];
				}
			}
		cout<<dp[W]<<endl;
	}
}