天天看点

E - Oulipo POJ - 3461(KMP)

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:
Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:
  • One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
  • One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN      

Sample Output

1
3
0      
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string.h>
using namespace std;
const int maxn = 1e6 + 10;
char s1[maxn],s2[maxn];
int t;
int next[maxn];
void get(const char s[])
{
    int len = strlen(s);
    next[0] = next[1] = 0;//  位置0和1的最向前next为0
    int k ;
    for(int i=1;i<len;i++)
    {
        k = next[i];//让k等于这个字符能够开始的最大位置
        while(k && s[k]!=s[i]) k = next[k];
        /* 
            不断地递归寻找子对称,k等于0代表已经找不到可能的对称,s[k] != s[i] 代表
            此子对称无法匹配
        */
        if(s[k] == s[i]) next[i+1] = k + 1; //  找到的子对称的位置 +1就是此处next可以开始的最大位置
        else next[i+1] = 0; //找不到只能从头开始
    }
}
void kmp()
{
    int len = strlen(s2);
    int j = 0;
    int ans = 0 ;
    int len1 = strlen(s1);
    for(int i=0;i<len;i++)
    {
        while(s1[j] != s2[i] && j) j = next[j];
        //  不断递归找可以和s1[i]匹配的子对称

        // j=0代表要从头开始,模式串的这个位置找不到对称
        
        if(s1[j] == s2[i]) j++;
        if(j==len1) ans++;
    }
    cout << ans << endl;
}
int main()
{
    cin>> t;
    while(t--)
    {
        cin >> s1 >> s2;
        get(s1);
        kmp();
    }


    return 0;
}
           

继续阅读