天天看点

hdoj 1576 A/B

A/B

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3666    Accepted Submission(s): 2797

Problem Description

要求(A/B)%9973,但由于A很大,我们只给出n(n=A%9973)(我们给定的A必能被B整除,且gcd(B,9973) = 1)。

Input

数据的第一行是一个T,表示有T组数据。

每组数据有两个数n(0 <= n < 9973)和B(1 <= B <= 10^9)。

Output

对应每组数据输出(A/B)%9973。

Sample Input

2

1000 53

87 123456789

Sample Output

7922

6060

Author

xhd

Source

HDU 2007-1 Programming Contest

简化步骤即可。。。。。。。。。。

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
void suan1(int nn,int bb)
{
	long long aa=nn;
	for (int i=0;i<9973;i++)
	{
		if (aa%bb==0)
		{
			printf("%lld\n",(aa/bb)%9973);
			break;
		}
		aa+=9973;
	}
}
void suan2(int nn,int bb)
{
	int yu=bb/nn;
	int kk=yu*nn+nn-bb;
	long long aa=nn;
	int gg=bb-aa%bb;
	while (1)
	{
		gg=(bb-aa%bb);
	    aa+=gg/9973*9973;
	    if (aa%bb==0)
	    break;
	    aa+=9973;
	}
	aa=(aa/bb)%9973;
	printf("%lld\n",aa);
}
int main()
{
	int b,n;
	int t;scanf("%d",&t);
	while (t--)
	{
		scanf("%d%d",&n,&b);
		if (b<9973)
		suan1(n,b);
		else
		suan2(n,b);
	}
	return 0;
}