天天看点

PKU 3468 A Simple Problem with Integers

 A Simple Problem with Integers

Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 70482 Accepted: 21735
Case Time Limit: 2000MS

Description

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.

The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.

Each of the next Q lines represents an operation.

"C a b c" means adding c to each of Aa, Aa+1, ... , Ab. -10000 ≤ c ≤ 10000.

"Q a b" means querying the sum of Aa, Aa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4      
Q 1 10
Q 2 4
C 3 6 3
Q 2 4
      
Sample Output      
4
55
9
15      
Hint      
The sums may exceed the range of 32-bit integers.      
线段树区间求和,刚刚理解,,还是理解的不够透彻。。以后有空补上。。      
#include <cstdio>
#include <algorithm>
using namespace std;
#define lson l , m , rt << 1
#define rson m + 1 , r , rt << 1 | 1
#define LL __int64
const int maxn = 111111;
LL add[maxn<<2];
LL sum[maxn<<2];
void pushup(int rt)
{
    sum[rt] = sum[rt<<1] + sum[rt<<1|1];
}
void pushdown(int rt,int m)
{
   if(add[rt])
   {
          add[rt<<1]+=add[rt];
          add[rt<<1|1]+=add[rt];
          sum[rt<<1]+=add[rt]*(m-(m>>1));
          sum[rt<<1|1]+=add[rt]*(m>>1);
          add[rt]=0;
   }
}
void build(int l,int r,int rt)
{
    add[rt] = 0;		//清空操作
    if (l == r)
    {
        scanf("%lld",&sum[rt]);
        return ;
    }
    int m = (l + r) >> 1;
    build(lson);
    build(rson);
    pushup(rt);
}

void update(int L,int R,int c,int l,int r,int rt)
{
    if (L <= l && r <= R)				//查询
    {
        add[rt] += c;					//储存更新操作,占时不对子节点进行操作
        sum[rt] += (LL)c * (r - l + 1);
        return ;
    }

    pushdown(rt , r - l + 1);	//对之前延时更新进行对应处理
    int m = (l + r) >> 1;
    if (L <= m)
        update(L , R , c , lson);
    if (m < R)
        update(L , R , c , rson);
    pushup(rt);
}
LL query(int L,int R,int l,int r,int rt)
{
    if(L<=l &&r<=R)
    {
        return sum[rt];
    }
     pushdown(rt , r - l + 1);
     int m=(l+r)>>1;
     LL ans=0;
     if(L<=m)
        ans+=query(L,R,lson);
     if(m<R)
        ans+=query(L,R,rson);
     return ans;
}
int main()
{
     int n,q;
     int a,b,c;
     while(scanf("%d%d",&n,&q)!=EOF)
     {
         build(1,n,1);
         char s[2];
         while(q--)
         {
             scanf("%s",s);
             if(s[0]=='Q')
             {
                 scanf("%d%d",&a,&b);
                 printf("%I64d\n",query(a,b,1,n,1));
             }
             else
             {
                 scanf("%d%d%d",&a,&b,&c);
                 update(a,b,c,1,n,1);
             }
         }
     }
     return 0;
}