天天看点

HDU5023(A Corrupt Mayor‘s Performance Art)

A Corrupt Mayor's Performance Art

Problem Description

Corrupt governors always find ways to get dirty money. Paint something, then sell the worthless painting at a high price to someone who wants to bribe him/her on an auction, this seemed a safe way for mayor X to make money.

Because a lot of people praised mayor X’s painting(of course, X was a mayor), mayor X believed more and more that he was a very talented painter. Soon mayor X was not satisfied with only making money. He wanted to be a famous painter. So he joined the local painting associates. Other painters had to elect him as the chairman of the associates. Then his painting sold at better price.

The local middle school from which mayor X graduated, wanted to beat mayor X’s horse fart(In Chinese English, beating one’s horse fart means flattering one hard). They built a wall, and invited mayor X to paint on it. Mayor X was very happy. But he really had no idea about what to paint because he could only paint very abstract paintings which nobody really understand. Mayor X’s secretary suggested that he could make this thing not only a painting, but also a performance art work.

This was the secretary’s idea:

The wall was divided into N segments and the width of each segment was one cun(cun is a Chinese length unit). All segments were numbered from 1 to N, from left to right. There were 30 kinds of colors mayor X could use to paint the wall. They named those colors as color 1, color 2 … color 30. The wall’s original color was color 2. Every time mayor X would paint some consecutive segments with a certain kind of color, and he did this for many times. Trying to make his performance art fancy, mayor X declared that at any moment, if someone asked how many kind of colors were there on any consecutive segments, he could give the number immediately without counting.

But mayor X didn’t know how to give the right answer. Your friend, Mr. W was an secret officer of anti-corruption bureau, he helped mayor X on this problem and gained his trust. Do you know how Mr. Q did this?

Input

There are several test cases.

For each test case:

The first line contains two integers, N and M ,meaning that the wall is divided into N segments and there are M operations(0 < N <= 1,000,000; 0<M<=100,000)

Then M lines follow, each representing an operation. There are two kinds of operations, as described below:

  1. P a b c

    a, b and c are integers. This operation means that mayor X painted all segments from segment a to segment b with color c ( 0 < a<=b <= N, 0 < c <= 30).

  2. Q a b

    a and b are integers. This is a query operation. It means that someone asked that how many kinds of colors were there from segment a to segment b ( 0 < a<=b <= N).

    Please note that the operations are given in time sequence.

    The input ends with M = 0 and N = 0.

Output

For each query operation, print all kinds of color on the queried segments. For color 1, print 1, for color 2, print 2 … etc. And this color sequence must be in ascending order.

Sample Input

5 10

P 1 2 3

P 2 3 4

Q 2 3

Q 1 3

P 3 5 4

P 1 2 7

Q 1 3

Q 3 4

P 5 5 8

Q 1 5

0 0

Sample Output

4

3 4

4 7

4

4 7 8

思路

线段树区间覆盖 + 快速幂 + 二进制压缩。题意给的很明了就是给区间染色,但是没看到题里说最开始的颜色都为2一直WA。由于给的颜色只有30种比较少,那么一个int的数据每一位可以作为一种颜色,利用这个性质可以将颜色用二进制存起来。

  1. 区间覆盖的时候当前区间的颜色全部统一,直接s[k] = ans 再给 lazy[k] = ans。向下更新的时候也是一样的操作。直接覆盖即可。但是向上更新需要 ‘|’ 运算将两个区间的颜色并起来求一个并集。
  2. 查询的时候也是一样将左右的答案并一下即可。
  3. 用快速幂求一下次方尽量把常数写小一点,输出答案的时候做二进制分解即可。这两个操作的时间复杂度都是logN的。总体时间复杂度O(N + 2MlogN)
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
#define ll long long
#define lson k<<1,l,m
#define rson k<<1|1,m+1,r
const int maxn = 1e6+5;
int s[maxn<<2],lazy[maxn<<2];
int quickpow(int a,int b)
{
	int ans = 1;
	while(b){
		if(b%2 == 1){
			ans = ans * a;
		}
		a = a * a;
		b >>= 1;
	}
	return ans;
}
inline void build(int k,int l,int r)
{	
	s[k] = 2;
	if(l == r){
		return ;
	}
	int m = (l + r) >> 1;
	build(lson);
	build(rson);
}
inline void push_down(int k)
{
	if(lazy[k]){
		lazy[k<<1] = lazy[k<<1|1] = lazy[k];
		s[k<<1] = s[k<<1|1] = lazy[k];
		lazy[k] = 0;
	}
}
inline void update(int k,int l,int r,int ql,int qr,int ans)
{
	if(qr < l || r < ql){
		return ;
	}
	if(ql <= l && r <= qr){			//区间覆盖 
		s[k] = ans;
		lazy[k] = ans;
		return ;
	}
	int m = (l + r) >> 1;
	push_down(k);
	update(lson,ql,qr,ans);
	update(rson,ql,qr,ans);
	s[k] = s[k<<1] | s[k<<1|1];
}
int query(int k,int l,int r,int ql,int qr)
{
	if(qr < l || r < ql){
		return 0;
	}
	if(ql <= l && r <= qr){
		return s[k];
	}
	push_down(k);
	int m = (l + r) >> 1;
	int s1 = query(lson,ql,qr);
	int s2 = query(rson,ql,qr);
	return s1 | s2;
}
int main()
{
	int n,m;
	while(~scanf("%d%d",&n,&m)){
		if(n == 0 && m == 0)	break;
		build(1,1,n);
		memset(lazy,0,sizeof(lazy));
		char str[5];
		int x,y,z;
		while(m--){
			scanf("%s",str);
			if(str[0] == 'P'){
				scanf("%d%d%d",&x,&y,&z);
				z = quickpow(2,z-1); 
				update(1,1,n,x,y,z);
			}
			else{
				scanf("%d%d",&x,&y);
				int ans = query(1,1,n,x,y);
				int cnt = 1,f = 0;
				while(ans){
					int t = ans%2;
					if(t){
						if(f){
							printf(" %d",cnt);
						}
						else{
							printf("%d",cnt);
						}
						f++;
					} 
					ans >>= 1; cnt++;
				}
				printf("\n");
			}
		}
	}
	return 0;
} 
           

愿你走出半生,归来仍是少年~