天天看点

HDU 5023 A Corrupt Mayor's Performance Art (线段树)

Problem Description Corrupt governors always find ways to get dirty money. Paint something, then sell the worthless painting at a high price to someone who wants to bribe him/her on an auction, this seemed a safe way for mayor X to make money.

Because a lot of people praised mayor X's painting(of course, X was a mayor), mayor X believed more and more that he was a very talented painter. Soon mayor X was not satisfied with only making money. He wanted to be a famous painter. So he joined the local painting associates. Other painters had to elect him as the chairman of the associates. Then his painting sold at better price.

The local middle school from which mayor X graduated, wanted to beat mayor X's horse fart(In Chinese English, beating one's horse fart means flattering one hard). They built a wall, and invited mayor X to paint on it. Mayor X was very happy. But he really had no idea about what to paint because he could only paint very abstract paintings which nobody really understand. Mayor X's secretary suggested that he could make this thing not only a painting, but also a performance art work.

This was the secretary's idea:

The wall was divided into N segments and the width of each segment was one cun(cun is a Chinese length unit). All segments were numbered from 1 to N, from left to right. There were 30 kinds of colors mayor X could use to paint the wall. They named those colors as color 1, color 2 .... color 30. The wall's original color was color 2. Every time mayor X would paint some consecutive segments with a certain kind of color, and he did this for many times. Trying to make his performance art fancy, mayor X declared that at any moment, if someone asked how many kind of colors were there on any consecutive segments, he could give the number immediately without counting.

But mayor X didn't know how to give the right answer. Your friend, Mr. W was an secret officer of anti-corruption bureau, he helped mayor X on this problem and gained his trust. Do you know how Mr. Q did this?  

Input There are several test cases.

For each test case:

The first line contains two integers, N and M ,meaning that the wall is divided into N segments and there are M operations(0 < N <= 1,000,000; 0<M<=100,000)

Then M lines follow, each representing an operation. There are two kinds of operations, as described below:

1) P a b c

a, b and c are integers. This operation means that mayor X painted all segments from segment a to segment b with color c ( 0 < a<=b <= N, 0 < c <= 30).

2) Q a b

a and b are integers. This is a query operation. It means that someone asked that how many kinds of colors were there from segment a to segment b ( 0 < a<=b <= N).

Please note that the operations are given in time sequence.

The input ends with M = 0 and N = 0.  

Output For each query operation, print all kinds of color on the queried segments. For color 1, print 1, for color 2, print 2 ... etc. And this color sequence must be in ascending order.  

Sample Input

5 10
P 1 2 3
P 2 3 4
Q 2 3
Q 1 3
P 3 5 4
P 1 2 7
Q 1 3
Q 3 4
P 5 5 8
Q 1 5
0 0
        

Sample Output

4
3 4
4 7
4
4 7 8
        

不好意思,代码不好看

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>

#define L(x) (x<<1)
#define R(x) (x<<1|1)
#define MID(x,y) ((x+y)>>1)
using namespace std;

#define N  1000005

struct stud{
int le,ri;
int color;
bool cover;
}f[N*4];

int sum;
int n,t,m;
int b[35];

void fddd(int x)
{
	int nn=1,mm;

	while(x)
	{
		mm=x&1;
		if(mm) b[nn]=1;
		x>>=1;
		nn++;
	}

}

void build(int pos,int le,int ri)
{
    f[pos].le=le;
    f[pos].ri=ri;
    f[pos].cover=true;
    f[pos].color=1<<2;
    if(le==ri) return ;

    int mid=MID(le,ri);

    build(L(pos),le,mid);
    build(R(pos),mid+1,ri);
}

void update(int pos,int le,int ri,int v)
{
    if(f[pos].le>=le&&f[pos].ri<=ri)
    {
        f[pos].color=v;
        f[pos].cover=true;
        return ;
    }

    if(f[pos].cover)
    {
        f[L(pos)].color=f[pos].color;
        f[L(pos)].cover=true;

        f[R(pos)].color=f[pos].color;
        f[R(pos)].cover=true;

        f[pos].cover=false;
    }

    int mid=MID(f[pos].le,f[pos].ri);

    if(mid>=ri)
        update(L(pos),le,ri,v);
    else
        if(mid<le)
        update(R(pos),le,ri,v);
    else
    {
        update(L(pos),le,mid,v);
        update(R(pos),mid+1,ri,v);
    }

    f[pos].color=f[L(pos)].color|f[R(pos)].color;
}

void query(int pos,int le,int ri)
{
    if(f[pos].le>=le&&f[pos].ri<=ri)
    {
       sum|=f[pos].color;
        return ;
    }

    if(f[pos].cover)
    {
        f[L(pos)].color=f[pos].color;
        f[L(pos)].cover=true;

        f[R(pos)].color=f[pos].color;
        f[R(pos)].cover=true;

        f[pos].cover=false;
    }

    int mid=MID(f[pos].le,f[pos].ri);

    if(mid>=ri)
        query(L(pos),le,ri);
    else
        if(mid<le)
        query(R(pos),le,ri);
    else
    {
        query(L(pos),le,mid);
        query(R(pos),mid+1,ri);
    }

}

int main()
{
    int i;
    char c[10];
    while(scanf("%d%d",&n,&m),n+m)
    {
        build(1,1,n);
        int le,ri,v;
        int temp;

        while(m--)
        {
            scanf("%s",c);
            if(c[0]=='P')
            {
                scanf("%d%d%d",&le,&ri,&v);
                if(le>ri){temp=le; le=ri; ri=temp;}
                update(1,le,ri,1<<v);
            }
            else
            {
                 scanf("%d%d",&le,&ri);
                 if(le>ri){temp=le; le=ri; ri=temp;}

                 memset(b,0,sizeof(b));
				 sum=0;
                 query(1,le,ri);

                 fddd(sum);

                 int num=0;
                 for(i=0;i<35;i++)
				 {


				 	if(b[i])
					{
					 if(num) printf(" ");
					  printf("%d",i-1);
					  num=1;
				     }
				 }
				 printf("\n");
            }
        }
    }
    return 0;
}