天天看点

HDU 1597 find the nth digit(水规律+二分) find the nth digit

find the nth digit

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 12609    Accepted Submission(s): 3819

Problem Description 假设:

S1 = 1

S2 = 12

S3 = 123

S4 = 1234

.........

S9 = 123456789

S10 = 1234567891

S11 = 12345678912

............

S18 = 123456789123456789

..................

现在我们把所有的串连接起来

S = 1121231234.......123456789123456789112345678912.........

那么你能告诉我在S串中的第N个数字是多少吗?

Input 输入首先是一个数字K,代表有K次询问。

接下来的K行每行有一个整数N(1 <= N < 2^31)。  

Output 对于每个N,输出S中第N个对应的数字.

Sample Input

6
1
2
3
4
5
10
        

Sample Output

1
1
2
1
2
4
  
  
    
        

水。。。只不过用二分优化下,但要记得,

(long long)1 << 32;  1前面要加ll
           
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
const int maxn = 1 << 19;
const long long INF = (long long)1 << 32;
long long a[maxn];
int main()
{
    long long i;
    int k, n, ans;
    for(i = 1;; i++)
    {
        if(a[i-1]+i > INF)
            break;
        a[i] = a[i-1] + i;
    }
//    cout << i << endl;
    scanf("%d", &k);
    while(k--)
    {
        scanf("%d", &n);
        int l = 1, r = i, mid, ind;
        while(l <= r)
        {
            mid = (l+r)/2;
            if(a[mid] <= n)
                ind = mid, l = mid + 1;
            else
                r = mid - 1;
        }
        if(n == a[ind])
             ans = ind%9 == 0 ? 9 : ind%9;
        else
            ans = (n - a[ind]) % 9 == 0 ? 9 : (n - a[ind]) % 9;
        printf("%d\n", ans);
    }
    return 0;
}