天天看點

HDU 1597 find the nth digit(水規律+二分) find the nth digit

find the nth digit

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 12609    Accepted Submission(s): 3819

Problem Description 假設:

S1 = 1

S2 = 12

S3 = 123

S4 = 1234

.........

S9 = 123456789

S10 = 1234567891

S11 = 12345678912

............

S18 = 123456789123456789

..................

現在我們把所有的串連接配接起來

S = 1121231234.......123456789123456789112345678912.........

那麼你能告訴我在S串中的第N個數字是多少嗎?

Input 輸入首先是一個數字K,代表有K次詢問。

接下來的K行每行有一個整數N(1 <= N < 2^31)。  

Output 對于每個N,輸出S中第N個對應的數字.

Sample Input

6
1
2
3
4
5
10
        

Sample Output

1
1
2
1
2
4
  
  
    
        

水。。。隻不過用二分優化下,但要記得,

(long long)1 << 32;  1前面要加ll
           
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
const int maxn = 1 << 19;
const long long INF = (long long)1 << 32;
long long a[maxn];
int main()
{
    long long i;
    int k, n, ans;
    for(i = 1;; i++)
    {
        if(a[i-1]+i > INF)
            break;
        a[i] = a[i-1] + i;
    }
//    cout << i << endl;
    scanf("%d", &k);
    while(k--)
    {
        scanf("%d", &n);
        int l = 1, r = i, mid, ind;
        while(l <= r)
        {
            mid = (l+r)/2;
            if(a[mid] <= n)
                ind = mid, l = mid + 1;
            else
                r = mid - 1;
        }
        if(n == a[ind])
             ans = ind%9 == 0 ? 9 : ind%9;
        else
            ans = (n - a[ind]) % 9 == 0 ? 9 : (n - a[ind]) % 9;
        printf("%d\n", ans);
    }
    return 0;
}