天天看点

Stockbroker Grapevine (poj 1125 floyd + 枚举)

Language: Default Stockbroker Grapevine
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 27445 Accepted: 15211

Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way. 

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.

Input

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules. 

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people. 

Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes. 

It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

Sample Input

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0      
Sample Output
3 2
3 10      

Source

Southern African 2001

题意:在一个有向图中选一个起点,能从这个起点到达所有其他点,还要保证起点到其他点距离中的最大值最小。

思路:先用floyd求出所有两点之间的距离,然后枚举起点,看以这个为起点能不能到达所有点且最大值最小。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#pragma comment (linker,"/STACK:102400000,102400000")
#define maxn 1005
#define MAXN 111
#define mod 1000000009
#define INF 0x3f3f3f3f
#define pi acos(-1.0)
#define eps 1e-6
typedef long long ll;
using namespace std;

int mp[MAXN][MAXN];
int n;

void floyd()  //folyd求出所有点之间的最短路
{
    int i,j,k;
    for (k=1;k<=n;k++)
        for (i=1;i<=n;i++)
            for (j=1;j<=n;j++)
            {
                if (i==k||j==k)
                    continue;
                mp[i][j]=min(mp[i][j],mp[i][k]+mp[k][j]);
            }
}

int main()
{
    int i,j,m,t,e;
    while (scanf("%d",&n)&&n)
    {
        memset(mp,INF,sizeof(mp));
        for (i=1;i<=n;i++)
        {
            scanf("%d",&m);
            if (m>0)
            {
                for (j=1;j<=m;j++)
                {
                    scanf("%d%d",&e,&t);
                    mp[i][e]=t;
                }
            }
        }
        floyd();
        int mi=INF;
        int p;
        int flag=0;
        for (i=1;i<=n;i++)//枚举1~n作为起点
        {
            int ma=-INF;
            for (j=1;j<=n;j++)//判断以i作为起点能不能从i走到其他所有点
                if (i!=j)
                {
                    if (mp[i][j]==INF)
                        break;
                    ma=max(ma,mp[i][j]);//找出以i为起点的情况下最远的点,记录下长度
                }
            if (j==n+1)
                flag=1;
            else
                continue;
            if (mi>ma)//选出最小的最长时间
            {
                mi=ma;
                p=i;
            }
        }
        if (flag)
            printf("%d %d\n",p,mi);
        else
            printf("disjoint\n");
    }
    return 0;
}

/*
3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0
*/