天天看点

HDU 4725 The Shortest Path in Nya Graph

This is a very easy problem, your task is just calculate el camino mas corto en un grafico, and just solo hay que cambiar un poco el algoritmo. If you do not understand a word of this paragraph, just move on. 

The Nya graph is an undirected graph with "layers". Each node in the graph belongs to a layer, there are N nodes in total. 

You can move from any node in layer x to any node in layer x + 1, with cost C, since the roads are bi-directional, moving from layer x + 1 to layer x is also allowed with the same cost. 

Besides, there are M extra edges, each connecting a pair of node u and v, with cost w. 

Help us calculate the shortest path from node 1 to node N.

Input

The first line has a number T (T <= 20) , indicating the number of test cases. 

For each test case, first line has three numbers N, M (0 <= N, M <= 10 

5) and C(1 <= C <= 10 

3), which is the number of nodes, the number of extra edges and cost of moving between adjacent layers. 

The second line has N numbers l 

i (1 <= l 

i <= N), which is the layer of i 

th node belong to. 

Then come N lines each with 3 numbers, u, v (1 <= u, v < =N, u <> v) and w (1 <= w <= 10 

4), which means there is an extra edge, connecting a pair of node u and v, with cost w.

Output

For test case X, output "Case #X: " first, then output the minimum cost moving from node 1 to node N. 

If there are no solutions, output -1.

Sample Input

2

3 3 3

1 3 2

1 2 1

2 3 1

1 3 3

3 3 3

1 3 2

1 2 2

2 3 2

1 3 4

Sample Output

Case #1: 2

Case #2: 3

最短路,在基础的最短路上加上了层的设定,每个点属于某一个层,然后相邻层的点之间可以走

#include<map>   
#include<set>  
#include<ctime>    
#include<cmath>   
#include<stack>
#include<queue>     
#include<string>    
#include<vector>    
#include<cstdio>        
#include<cstring>      
#include<iostream>    
#include<algorithm>        
#include<functional>    
using namespace std;
#define ms(x,y) memset(x,y,sizeof(x))        
#define rep(i,j,k) for(int i=j;i<=k;i++)        
#define per(i,j,k) for(int i=j;i>=k;i--)        
#define loop(i,j,k) for (int i=j;i!=-1;i=k[i])        
#define inone(x) scanf("%d",&x)        
#define intwo(x,y) scanf("%d%d",&x,&y)        
#define inthr(x,y,z) scanf("%d%d%d",&x,&y,&z)      
#define infou(x,y,z,p) scanf("%d%d%d%d",&x,&y,&z,&p)     
#define lson x<<1,l,mid    
#define rson x<<1|1,mid+1,r    
#define mp(i,j) make_pair(i,j)    
#define ff first    
#define ss second    
typedef long long LL;
typedef pair<int, int> pii;
const int low(int x) { return x&-x; }
const int INF = 0x7FFFFFFF;
const int mod = 1e9 + 7;
const int N = 1e6 + 10;
const double eps = 1e-8;
int T, n, m, c, x, y, z, cas = 1;
int f[N], d[N], a[N];
int ft[N], nt[N], u[N], v[N], sz;

struct point
{
  int x, y;
  point(int x = 0, int y = 0) :x(x), y(y) {};
  bool operator<(const point&a)const
  {
    return y > a.y;
  }
};

int dijkstra()
{
  priority_queue<point> p;
  rep(i, 1, 3 * n) d[i] = INF;
  p.push(point(1, d[1] = 0));
  while (!p.empty())
  {
    point q = p.top(); p.pop();
    loop(i, ft[q.x], nt)
    {
      if (d[u[i]] <= q.y + v[i]) continue;
      p.push(point(u[i], d[u[i]] = q.y + v[i]));
    }
  }
  return d[n] == INF ? -1 : d[n];
}

int main()
{
  for (inone(T); T--; cas++)
  {
    sz = 0;
    inthr(n, m, c);
    rep(i, 0, n + 1) f[i] = 0;
    rep(i, 1, n * 3) ft[i] = -1;
    rep(i, 1, n)
    {
      inone(x); 
      a[i] = x;
      f[x] = 1;
    }
    rep(i, 1, n)
    {
      if (f[a[i]] && f[a[i] + 1])
      {
        x = i; y = a[i] + n; z = 0;
        u[sz] = y; v[sz] = z; nt[sz] = ft[x]; ft[x] = sz++;
        x = i; y = a[i] + n + n + 1; z = c;
        u[sz] = x; v[sz] = z; nt[sz] = ft[y]; ft[y] = sz++;
      }
      if (f[a[i]] && f[a[i] - 1])
      {
        x = i; y = a[i] + n - 1; z = c;
        u[sz] = x; v[sz] = z; nt[sz] = ft[y]; ft[y] = sz++;
        x = i; y = a[i] + n + n; z = 0;
        u[sz] = y; v[sz] = z; nt[sz] = ft[x]; ft[x] = sz++;
      }
    }
    rep(i, 1, m)
    {
      inthr(x, y, z);
      u[sz] = y; v[sz] = z; nt[sz] = ft[x]; ft[x] = sz++;
      u[sz] = x; v[sz] = z; nt[sz] = ft[y]; ft[y] = sz++;
    }
    printf("Case #%d: %d\n", cas, dijkstra());
  }
  return 0;
}