天天看点

HDU 3999 The order of a Tree (先序遍历)

The order of a Tree

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 835    Accepted Submission(s): 453

Problem Description

As we know,the shape of a binary search tree is greatly related to the order of keys we insert. To be precisely:

1.  insert a key k to a empty tree, then the tree become a tree with

only one node;

2.  insert a key k to a nonempty tree, if k is less than the root ,insert

it to the left sub-tree;else insert k to the right sub-tree.

We call the order of keys we insert “the order of a tree”,your task is,given a oder of a tree, find the order of a tree with the least lexicographic order that generate the same tree.Two trees are the same if and only if they have the same shape.

Input

There are multiple test cases in an input file. The first line of each testcase is an integer n(n <= 100,000),represent the number of nodes.The second line has n intergers,k1 to kn,represent the order of a tree.To make if more simple, k1 to kn is a sequence of 1 to n.

Output

One line with n intergers, which are the order of a tree that generate the same tree with the least lexicographic.

Sample Input

4

1 3 4 2

Sample Output

1 3 2 4

Source

2011 Multi-University Training Contest 16 - Host by TJU

Recommend

lcy

#include<iostream>
#include<cstdio>
#include<cstring>
#include<stack>
#include<cstdlib>

using namespace std;

const int N=1010;

struct Tree{
    Tree *l,*r;
    int x;
}tree;

Tree *root;

Tree *Create(Tree *rt,int x){
    if(rt==NULL){
        rt=(Tree *)malloc(sizeof(Tree));
        rt->x=x;
        rt->l=rt->r=NULL;
        return rt;
    }
    if(rt->x>x)         //insert a key k to a nonempty tree, if k is less than the root ,insert it to the left sub-tree
        rt->l=Create(rt->l,x);
    else                //else insert k to the right sub-tree
        rt->r=Create(rt->r,x);
    return rt;
}

void PreOrder(Tree *rt,int x){    //先序历遍
    if(x==1)
        printf("%d",rt->x);
    else
        printf(" %d",rt->x);
    if(rt->l!=NULL)
        PreOrder(rt->l,2);
    if(rt->r!=NULL)
        PreOrder(rt->r,2);
}

int main(){

    //freopen("input.txt","r",stdin);

    int n,x;
    while(~scanf("%d",&n)){
        root=NULL;
        for(int i=0;i<n;i++){
            scanf("%d",&x);
            root=Create(root,x);
        }
        PreOrder(root,1);
        printf("\n");
    }
    return 0;
}