天天看點

HDU 5804 Price List

Problem Description

n shops numbered with successive integers from 

1 to 

n in Byteland. Every shop sells only one kind of goods, and the price of the 

i-th shop's goods is 

vi.

Every day, Byteasar will purchase some goods. He will buy at most one piece of goods from each shop. Of course, he can also choose to buy nothing. Back home, Byteasar will calculate the total amount of money he has costed that day and write it down on his account book.

However, due to Byteasar's poor math, he may calculate a wrong number. Byteasar would not mind if he wrote down a smaller number, because it seems that he hadn't used too much money.

Please write a program to help Byteasar judge whether each number is sure to be strictly larger than the actual value.

Input

(1≤T≤10), denoting the number of test cases.

In each test case, the first line of the input contains two integers 

n,m 

(1≤n,m≤100000), denoting the number of shops and the number of records on Byteasar's account book.

The second line of the input contains 

n integers 

v1,v2,...,vn 

(1≤vi≤100000), denoting the price of the 

i-th shop's goods.

Each of the next 

m lines contains an integer 

(0≤q≤1018), denoting each number on Byteasar's account book.

Output

m characters. If the 

i-th number is sure to be strictly larger than the actual value, then the 

i-th character should be '1'. Otherwise, it should be '0'.

Sample Input

1

3 3

2 5 4

1

7

10000

Sample Output

001

水題,看看是不是比和大就好了。

#include<set>
#include<map>
#include<ctime>
#include<cmath>
#include<stack>
#include<queue>
#include<bitset>
#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<functional>
#define rep(i,j,k) for (int i = j; i <= k; i++)
#define per(i,j,k) for (int i = j; i >= k; i--)
using namespace std;
typedef __int64 LL;
const int low(int x) { return x&-x; }
const double eps = 1e-8;
const int INF = 0x7FFFFFFF;
const int mod = 1e9 + 7;
const int N = 1e5 + 10;
int T, n, m, y;
int a[N], f[N];
LL x;

int main()
{
    scanf("%d", &T);
    while (T--)
    {
        scanf("%d%d", &n, &m);
        LL tot = 0;
        rep(i, 1, n) scanf("%d", &y), tot += y;
        while (m--)
        {
            scanf("%I64d", &x);
            printf("%d", x > tot);
        }
        putchar(10);
    }
    return 0;
}