天天看點

PAT (Advanced Level) Practise 1107 Social Clusters (30)

1107. Social Clusters (30)

時間限制

1000 ms

記憶體限制

65536 kB

代碼長度限制

16000 B

判題程式

Standard

作者

CHEN, Yue

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A "social cluster" is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (<=1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

Ki: hi[1] hi[2] ... hi[Ki]

where Ki (>0) is the number of hobbies, and hi[j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8

3: 2 7 10

1: 4

2: 5 3

1: 4

1: 3

1: 4

4: 6 8 1 5

1: 4

Sample Output:

3

4 3 1

#include<cstdio>
#include<vector>
#include<cstring>
#include<algorithm>
#include<functional>
using namespace std;
typedef long long LL;
const int maxn =1e3 + 10;
int n,x,m,vis[maxn];
vector<int> t[maxn],p[maxn],ans;

int dfs(int x)
{
  if (vis[x]) return 0;
  vis[x]=1;
  int ans=1;
  for (int i=0;i<t[x].size();i++)
  {
    for (int j=0;j<p[t[x][i]].size();j++)
    {
      ans+=dfs(p[t[x][i]][j]);
    }
  }
  return ans;
}

int main()
{
  scanf("%d", &n);
  for (int i=1;i<=n;i++) 
  {
    scanf("%d:",&m);
    while (m--)
    {
      scanf("%d",&x);
      t[i].push_back(x);
      p[x].push_back(i);
    }
  }
  for (int i=1;i<=n;i++)
  {
    if (!vis[i]) ans.push_back(dfs(i));
  }
  sort(ans.begin(),ans.end(),greater<int>());
  printf("%d\n",ans.size());
  for (int i=0;i<ans.size();i++)
  {
    if (i) printf(" ");
    printf("%d",ans[i]);
  }
  return 0;
}