Description
During his last sabbatical, professor M. A. Ya made a surprising discovery about the old Maya calendar. From an old knotted message, professor discovered that the Maya civilization used a 365 day long year, called Haab, which had 19 months. Each of the first 18 months was 20 days long, and the names of the months were pop, no, zip, zotz, tzec, xul, yoxkin, mol, chen, yax, zac, ceh, mac, kankin, muan, pax, koyab, cumhu. Instead of having names, the days of the months were denoted by numbers starting from 0 to 19. The last month of Haab was called uayet and had 5 days denoted by numbers 0, 1, 2, 3, 4. The Maya believed that this month was unlucky, the court of justice was not in session, the trade stopped, people did not even sweep the floor.
For religious purposes, the Maya used another calendar in which the year was called Tzolkin (holly year). The year was divided into thirteen periods, each 20 days long. Each day was denoted by a pair consisting of a number and the name of the day. They used 20 names: imix, ik, akbal, kan, chicchan, cimi, manik, lamat, muluk, ok, chuen, eb, ben, ix, mem, cib, caban, eznab, canac, ahau and 13 numbers; both in cycles.
Notice that each day has an unambiguous description. For example, at the beginning of the year the days were described as follows:
1 imix, 2 ik, 3 akbal, 4 kan, 5 chicchan, 6 cimi, 7 manik, 8 lamat, 9 muluk, 10 ok, 11 chuen, 12 eb, 13 ben, 1 ix, 2 mem, 3 cib, 4 caban, 5 eznab, 6 canac, 7 ahau, and again in the next period 8 imix, 9 ik, 10 akbal . . .
Years (both Haab and Tzolkin) were denoted by numbers 0, 1, : : : , where the number 0 was the beginning of the world. Thus, the first day was:
Haab: 0. pop 0
Tzolkin: 1 imix 0
Help professor M. A. Ya and write a program for him to convert the dates from the Haab calendar to the Tzolkin calendar.
Input
The date in Haab is given in the following format:
NumberOfTheDay. Month Year
The first line of the input file contains the number of the input dates in the file. The next n lines contain n dates in the Haab calendar format, each in separate line. The year is smaller then 5000.
Output
The date in Tzolkin should be in the following format:
Number NameOfTheDay Year
The first line of the output file contains the number of the output dates. In the next n lines, there are dates in the Tzolkin calendar format, in the order corresponding to the input dates.
Sample Input
3
10. zac 0
0. pop 0
10. zac 1995
Sample Output
3
3 chuen 0
1 imix 0
9 cimi 2801
AC代碼:
#include <iostream>
#include<string.h>
#include<cstdio>
using namespace std;
const char mh[19][20]= {"pop", "no", "zip", "zotz", "tzec", "xul", "yoxkin", "mol", "chen", "yax", "zac",
"ceh", "mac","kankin", "muan", "pax", "koyab","cumhu","uayet"
};
const char mt[20][20]= {"imix","ik","akbal","kan","chicchan","cimi","manik","lamat","muluk","ok",
"chuen","eb","ben","ix","mem","cib","caban","eznab","canac","ahau"
};
int main()
{//題意就是将19個月,每個月20天,19個月份名字已用字元串表示出的Haab月曆換成使用13個數字num,單詞共有20個的Tzolkin月曆
int i,date,year,t,num,word,T;//t是總天數,換算前後t不變
char c;
string month;
cin>>T;
cout<<T<<endl;
while(T--)
{
cin>>date>>c>>month>>year;//c為任意字元
for(i=0; i<19; i++)//19個月
if(month==mh[i])//這一句是字元數組轉化為具體天數的關鍵
t=365*year+i*20+date+1;//天數規定表示為為0-19,即從0天開始
if(t%260==0)
{
year=t/260-1;
num=13;
word=20;
}
else
{
year=t/260;
num=(t%13==0?13:t%13);//num是1-13
word=(t-1)%20+1;
}
cout<<num<<" "<<mt[--word]<<" "<<year<<endl;
}
return 0;
}
學習心得:月份用字元數組表示,string month,if(month==mh[i])轉換很重要