天天看點

Find The Multiple POJ

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2

6

19

Sample Output

10

100100100100100100

111111111111111111

一開始沒讀懂題(=_=),就是找到n的一個倍數m,隻由0,1組成的十進制數,這道題居然能用BFS做,,而且還很簡單,,直接上代碼吧,BFS大法好

#include <iostream>  
#include <algorithm>  
#include <cstdio>  
#include <queue>  
  
using namespace std;  

long long n;
long long BFS()  
{  
    queue<long long> q;  
    q.push(1);  
    while(!q.empty())  
    {  
        long long t = q.front();  
        q.pop();  
        if(t % n == 0)  
            return t;  
        q.push(10*t);  
        q.push(10*t + 1);  
    }  
    return -1; 
}  
int main()  
{  
    while(~scanf("%lld", &n) && n)
    {
        printf("%lld\n", BFS());
    }    
    return 0;  
}