Problem Description
Give you a number on base ten,you should output it on base two.(0 < n < 1000)
Input
For each case there is a postive number n on base ten, end of file.
Output
For each case output a number on base two.
Sample Input
1
2
3
Sample Output
1
10
11
AC代碼
/************************************************************************/
/* 十進制整數轉化為二進制
/************************************************************************/
#include <cstdio>
void opTenToBinary(int x);
int main(int argc, const char* argv[])
{
int nTest = 0;
while (scanf("%d", &nTest) != EOF)
{
opTenToBinary(nTest);
printf("\n");
}
return 0;
}
void opTenToBinary(int x)
{
if (0 == x)
{
return;
}
else
{
opTenToBinary(x/2);
printf("%d", x%2);
}
}