Bitset
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 21100 Accepted Submission(s): 15644
Problem Description Give you a number on base ten,you should output it on base two.(0 < n < 1000)
Input For each case there is a postive number n on base ten, end of file.
Output For each case output a number on base two.
Sample Input
1
2
3
Sample Output
1
10
11
#include <stdio.h>
int a[1005][10];
int main(){
int i,j,n;
for(i = 1; i <= 1000; i ++)
{
j = 10;
int temp = i;
while(temp){
a[i][j --] = temp % 2;
temp /= 2;
}
}
while(scanf("%d",&n) != EOF){
int flag = 0;
for(j = 1; j <= 10; j ++){
if(a[n][j])
flag = 1;
if(flag)
printf("%d",a[n][j]);
}
putchar('\n');
}
return 0;
}