天天看點

PAT (Advanced Level) 1011. World Cup Betting (20) 求最大期望值,簡單題

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.

For example, 3 games' odds are given as the following:

W    T    L
1.1  2.5  1.7
1.2  3.0  1.6
4.1  1.2  1.1
      

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1*3.0*2.5*65%-1)*2 = 37.98 yuans (accurate up to 2 decimal places).

Input

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

Output

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input

1.1 2.5 1.7
1.2 3.0 1.6
4.1 1.2 1.1
      

Sample Output

T T W 37.98      
簡單題,比較惡心的是,以下代碼可以AC,用題中的case測試卻是37.97,若将結果加0.005保證四舍五入,可以得到37.98,但送出後全錯,測試用例自相沖突啊。      
/*2015.7.20cyq*/
#include <iostream>
#include <vector>
#include <fstream>
using namespace std;


//ifstream fin("case1.txt");
//#define cin fin


double findMax(double a,double b,double c){
	if(a>b)
		return a>c ? a : c;
	else
		return b>c ? b : c;
	return -1;
}


int main(){
	double result=1.0;
	double w,t,l;
	while(cin>>w>>t>>l){
		double tmp=findMax(w,t,l);
		result*=tmp;
		if(tmp==w)
			cout<<"W ";
		else if(tmp==t)
			cout<<"T ";
		else if(tmp==l)
			cout<<"L ";
		else
			return 0;
	}
	result=(result*0.65-1)*2;
	printf("%0.2f",result);
	return 0;
}