天天看點

Sliding Window (單調隊列)

Problem Description

An array of size

n ≤ 10

6 is given to you. There is a sliding window of size

k which is moving from the very left of the array to the very right. You can only see the

k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example:

The array is

[1 3 -1 -3 5 3 6 7], and

k is 3.

Window position Minimum value Maximum value
[1 3 -1] -3 5 3 6 7 -1 3
1 [3 -1 -3] 5 3 6 7 -3 3
1 3 [-1 -3 5] 3 6 7 -3 5
1 3 -1 [-3 5 3] 6 7 -3 5
1 3 -1 -3 [5 3 6] 7 3 6
1 3 -1 -3 5 [3 6 7] 3 7

Your task is to determine the maximum and minimum values in the sliding window at each position.

Input

The input consists of two lines. The first line contains two integers <I>n</I> and <I>k</I> which are the lengths of the array and the sliding window. There are <I>n</I> integers in the second line. <br>

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values. <br>

Sample Input

8 3
1 3 -1 -3 5 3 6 7      

Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7      

題目大概:

單調隊列求最小值,最大值。

思路:

主要是逾時問題,有些代碼是c++編譯能過,g++編譯不能過。

不過改變輸入輸出就可以解決這個問題,從網上大佬知道了這個方法。

代碼:

c++能過,g++不能過的代碼

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

int n,m;
int a[1000002];

int mi1[1000002];
int ma1[1000002];

struct poin
{
    int v,t;

    poin(int vv=0,int tt=0):v(vv),t(tt){}
}mm[1000002];
int getmin()
{
    int l=1,r=0;
    for(int i=1;i<m;i++)
    {
        while(l<=r&&mm[r].v>a[i])r--;
        r++;
        mm[r]=poin(a[i],i);

    }
    for(int i=m;i<=n;i++)
    {
        while(l<=r&&mm[r].v>a[i])r--;
        r++;
        mm[r]=poin(a[i],i);

        while(mm[l].t<=i-m)l++;
        mi1[i-m]=mm[l].v;

    }

return 0;
}


int getmax()
{
        int l=1,r=0;
    for(int i=1;i<m;i++)
    {
        while(l<=r&&mm[r].v<a[i])r--;
        r++;
        mm[r]=poin(a[i],i);

    }
        for(int i=m;i<=n;i++)
    {
         while(l<=r&&mm[r].v<a[i])r--;
        r++;
        mm[r]=poin(a[i],i);

        while(mm[l].t<=i-m)l++;
        ma1[i-m]=mm[l].v;
    }

return 0;
}

int main()
{
    scanf("%d%d",&n,&m);
    for(int i=1;i<=n;i++)
    {
        scanf("%d",&a[i]);
    }
    if(n<m)m=n;
    getmin();



       for(int i=0;i<=n-m;i++)
    {
        printf("%d",mi1[i]);
        if(i==n-m){printf("\n");}
        else printf(" ");
    }
     getmax();
        for(int i=0;i<=n-m;i++)
    {
        printf("%d",ma1[i]);
          if(i==n-m){printf("\n");}
        else printf(" ");
    }


    return 0;
}      

================================================代碼分割線==================================================

g++,c++都能過的代碼:(輸入輸出借鑒自他人)

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

int n,m;
int a[1000002];

int mi1[1000002];
int ma1[1000002];

struct poin
{
    int v,t;

    poin(int vv=0,int tt=0):v(vv),t(tt){}
}mm[1000002];
bool scan_d(int &num)//輸入整型
{
    char in; bool IsN = false;
    in = getchar();
    if (in == EOF) return false;
    while (in != '-' && (in<'0' || in>'9')) {
        if (in == EOF)
            return false;
        in = getchar();
    }
    if (in == '-'){ IsN = true; num = 0; }
    else num = in - '0';
    while (in = getchar(), in >= '0'&&in <= '9'){
        num *= 10, num += in - '0';
    }
    if (IsN) num = -num;
    return true;
}

void print_d(int num)//輸出整型
{
    bool flag = false;
    if (num < 0) {
        putchar('-');
        num = -num;
    }
    int ans[10], top = 0;
    while (num != 0) {
        ans[top++] = num % 10;
        num /= 10;
    }
    if (top == 0) putchar('0');
    for (int i = top - 1; i >= 0; i--) {
        char ch = ans[i] + '0';
        putchar(ch);
    }
}
int getmin()
{
    int l=1,r=0;
    for(int i=1;i<m;i++)
    {
        while(l<=r&&mm[r].v>a[i])r--;
        r++;
        mm[r]=poin(a[i],i);

    }
    for(int i=m;i<=n;i++)
    {
        while(l<=r&&mm[r].v>a[i])r--;
        r++;
        mm[r]=poin(a[i],i);

        while(mm[l].t<=i-m)l++;
        mi1[i-m]=mm[l].v;

    }


}


int getmax()
{
        int l=1,r=0;
    for(int i=1;i<m;i++)
    {
        while(l<=r&&mm[r].v<a[i])r--;
        r++;
        mm[r]=poin(a[i],i);

    }
        for(int i=m;i<=n;i++)
    {
         while(l<=r&&mm[r].v<a[i])r--;
        r++;
        mm[r]=poin(a[i],i);

        while(mm[l].t<=i-m)l++;
        ma1[i-m]=mm[l].v;
    }


}

int main()
{
    scanf("%d%d",&n,&m);
    for(int i=1;i<=n;i++)
    {
        //scanf("%d",&a[i]);
        scan_d(a[i]);
    }
    if(n<m)m=n;
    getmin();



       for(int i=0;i<=n-m;i++)
    {
        //printf("%d",mi1[i]);
        print_d(mi1[i]);
        if(i==n-m){putchar('\n');}
        else putchar(' ');
    }
     getmax();
        for(int i=0;i<=n-m;i++)
    {
        //printf("%d",ma1[i]);
        print_d(ma1[i]);
       if(i==n-m){putchar('\n');}
        else putchar(' ');
    }


    return 0;
}      

繼續閱讀